4

I've been at this for hours now. Nothing works, .desktop file below. I don't know why, but I can't drag&drop the open firefox-dev icon to my favorites, only when I look for it in Applications windows and drag it from there. But that way it just opens a new icon instead. Before this issue gets closed for a mildly similar question, below are all of the solutions I've tried.

[Desktop Entry]
Version=1.0
Name=Firefox Developer Edition
StartupWMClass="firefox-aurora", "Firefox Developer Edition"
GenericName=Web Browser
Exec=/opt/firefox/firefox %u
Terminal=false
Icon=/opt/firefox/browser/chrome/icons/default/default128.png
Type=Application
Categories=Network;WebBrowser;Favorites;
MimeType=text/html;text/xml;application/xhtml_xml;x-scheme-handler/http;x-scheme-handler/https;x-scheme-handler/ftp;
X-Ayatana-Desktop-Shortcuts=NewWindow;NewIncognito

I've tried:

Cannot add custom launcher to Ubuntu Dock ('Add to Favorites' option does not show up)

Ubuntu Dock adds a new icon when I open certain programs

Duplicate icons for manually created GNOME launcher items

How do I install the Firefox Developer Edition?

Firefox developer edition icon duplication in Gnome shell

6
  • Read this it may help you.how2shout.com/linux/…
    – David
    Mar 16, 2022 at 13:05
  • Doesn't help unfortunately. I tried using the default Firefox .desktop file as base and change the path but it doesn't work so yeah. This really sucks. I was really hoping Ubuntu is just install and go but this is still considered a basic thing and I've been troubleshooting for hours now. Obviously it's not all Ubuntu's fault Firefox developers have you download a tar instead of a .deb or something simple.
    – shook_one
    Mar 16, 2022 at 13:31
  • Then maybe look into Firefox support site.
    – David
    Mar 16, 2022 at 13:38
  • Support sites are useless, though.
    – shook_one
    Mar 16, 2022 at 13:39
  • OK if you say so this is a support site and you posted your question here.
    – David
    Mar 16, 2022 at 13:40

2 Answers 2

2

setting StartupWMClass as

StartupWMClass=firefox-aurora

fixed my issue.

below StartupWMClasses doesn't work for me.

StartupWMClass="firefox-aurora", "Firefox Developer Edition"
StartupWMClass=Firefox Developer Edition

my desktop entry

[Desktop Entry]
Name=Firefox Developer 
GenericName=Firefox Developer Edition
Exec=/opt/firefox/firefox %u
Terminal=false
Icon=/opt/firefox/browser/chrome/icons/default/default128.png
Type=Application
Categories=Application;Network;X-Developer;
Comment=Firefox Developer Edition Web Browser.
StartupWMClass=firefox-aurora
StartupNotify=true
2

I had this exact problem, then I removed Firefox Developer Edition from favorites, and I lost the ability to add it to favorites again (that option was missing from the right-click context menu).

This answer you linked to, Firefox developer edition icon duplication in Gnome shell, helped me solve this issue, here's my /usr/share/applications/firefox-developer-edition.desktop (the naming could be relevant, not sure):

[Desktop Entry]
Version=1.0
Name=Firefox Developer Edition 
GenericName=Firefox Developer
Exec=/usr/bin/firefox-developer-edition/firefox --class "Firefox Developer Edition"
Terminal=false
Icon=/usr/bin/firefox-developer-edition/browser/chrome/icons/default/default128.png
Type=Application
Categories=Application;Network;X-Developer;
Comment=Firefox Developer Edition Web Browser.
StartupWMClass=Firefox Developer Edition

What fixed the problem for me was adding --class "Firefox Developer Edition" to the Exec line, but I'm guessing consistent naming matters as well.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .