OS Ubuntu 20.04 VirtualBox 6.1.32_Ubuntur149290 Running Windows 10

I got this following error and I have work inside my VirtualBox that I really do not want to lose.


dpkg --list virtualbox-*
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name                           Version                       Architecture D>
un  virtualbox-2.0                 <none>                        <none>       (>
un  virtualbox-2.1                 <none>                        <none>       (>
un  virtualbox-2.2                 <none>                        <none>       (>
un  virtualbox-3.0                 <none>                        <none>       (>
un  virtualbox-3.1                 <none>                        <none>       (>
un  virtualbox-3.2                 <none>                        <none>       (>
un  virtualbox-4.0                 <none>                        <none>       (>
un  virtualbox-4.1                 <none>                        <none>       (>
un  virtualbox-4.2                 <none>                        <none>       (>
un  virtualbox-4.3                 <none>                        <none>       (>
un  virtualbox-5.0                 <none>                        <none>       (>
un  virtualbox-5.1                 <none>                        <none>       (>
un  virtualbox-5.2                 <none>                        <none>       (>
un  virtualbox-6.0                 <none>                        <none>       (>
un  virtualbox-6.1                 <none>                        <none>       (>
ii  virtualbox-dkms                6.1.26-dfsg-3~ubuntu1.20.04.2 amd64        x>
ii  virtualbox-ext-pack            6.1.32-1~ubuntu1.20.04.1      all          e>
un  virtualbox-guest-additions-iso <none>                        <none>       (>
un  virtualbox-guest-modules       <none>                        <none>       (>
un  virtualbox-modules             <none>                        <none>       (>
ii  virtualbox-qt                  6.1.32-dfsg-1~ubuntu1.20.04.1 amd64        x>
un  virtualbox-source              <none>                        <none>       (>

I have found a similar problem here. But I am not sure if this will delete my current work the virtualBox and I do have enough rep to ask further questions on the original post. Please help.

I also run this and it seems like I have the correct architect for my OS

spock@spock-uss:~$ dpkg -l virtualbox* | grep ^i
ii  virtualbox                     6.1.32-dfsg-1~ubuntu1.20.04.1 amd64        x86 virtualization solution - base binaries
ii  virtualbox-dkms                6.1.26-dfsg-3~ubuntu1.20.04.2 amd64        x86 virtualization solution - kernel module sources for dkms
ii  virtualbox-ext-pack            6.1.32-1~ubuntu1.20.04.1      all          extra capabilities for VirtualBox, downloader.
ii  virtualbox-qt                  6.1.32-dfsg-1~ubuntu1.20.04.1 amd64        x86 virtualization solution - Qt based user interface


2 Answers 2


I found the solution to this problem. In Synaptic Package Manager I found that the package 6.1.26-dfsg-1~ubuntu1.20.04.1 was not of the right version (had an exclamation mark). I updated this package to 6.1.32-dfsg-1~ubuntu1.20.04.1 and now virtualbox is running without problems.


I ran into the same problem last Sunday (hadn't used the vm for a few weeks) however today it's solved :)

I've done the following actions: Sunday

  • apt remove virtualbox virtualbox-ext-pack
  • apt install virtualbox virtualbox-ext-pack
  • reboot, no effect
  • apt-get install virtualbox-dkms
  • reboot, no effect
  • apt autoremove
  • reboot, no effect
  • shutdown laptop


  • restart laptop
  • executed the (daily) Ubuntu updates from today

and.... Virtualbox with my Windows vm starts without problems :) no idea why.

Todays Ubuntu update Upgrade: netplan.io:amd64 (0.103-0ubuntu5~20.04.5, 0.103-0ubuntu5~20.04.6), libxml2-dev:amd64 (2.9.10+dfsg-5ubuntu0.20.04.1, 2.9.10+dfsg-5ubuntu0.20.04.2), python-libxml2:amd64 (2.9.10+dfsg-5ubuntu0.20.04.1, 2.9.10+dfsg-5ubuntu0.20.04.2), libnetplan0:amd64 (0.103-0ubuntu5~20.04.5, 0.103-0ubuntu5~20.04.6), libxml2:amd64 (2.9.10+dfsg-5ubuntu0.20.04.1, 2.9.10+dfsg-5ubuntu0.20.04.2), libxml2:i386 (2.9.10+dfsg-5ubuntu0.20.04.1, 2.9.10+dfsg-5ubuntu0.20.04.2)

hope this helps you too. best regards Lodewijk


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .