I bought a new laptop with a RTL8723AE-BT wireless card, but it seems there is nothing that makes it work.

Realtek usually makes drivers available for its card, but this specific one doesn't have a driver available on Realtek's website. I have tried the following steps in order to try and make it work:

  1. Installed ndiswrapper versions 1.57 (from repositories, with dkms) and 1.58rc1 (compiled from source from ndiswrapper's website). Both failed: version 1.57 does not provide an interface for the functions IoWMIOpenBlock and IoWMIQueryAllData. 1.58rc1 has dummy functions in their places, but it fails with a "ioremap failed" message.

    Upon further investigation, I have found that the function NdisMMapIOSpace (ndis.c:808), in 1.58rc1, gets called with physical address and length zero, which causes the failure. Since this function doesn't seem to be called from anywhere in ndiswrapper's code, I'd assume the Windows driver is somehow calling it with bogus parameters.

  2. I tried using both the 64-bit version (on my installed system, which uses the x86_64 version of Ubuntu) and the 32-bit version (on a live-USB x86 system with persistence enabled) of the Windows XP driver. The same errors occurred for both versions.

  3. Since Realtek's Linux drivers for RTL8192CE/SE/DE actually mention the 8723 chipset in its sources, I tried compiling them and modprobing them, but they don't pick up the card ID (10ec:8723). I also tried to echo 10ec 8723 > new_id on the sysfs (/sys/bus/pci/drivers/rtl8192de) location ( of the driver (actually, on each of them, one at a time), but I get a "Permission denied" error even with sudo. If I sudo su and try again, I get the error bash: echo: write error: Invalid argument.

I have run out of ideas. It's really frustrating to buy a new notebook to use only with Ubuntu and not be able to use its wi-fi connection.

If anyone can shed a light on alternatives, I'd be very thankful.

Edit: lshw -C network output

$ sudo lshw -C network -numeric
  *-network UNCLAIMED     
       description: Network controller
       product: Realtek Semiconductor Co., Ltd. [10EC:8723]
       vendor: Realtek Semiconductor Co., Ltd. [10EC]
       physical id: 0
       bus info: pci@0000:03:00.0
       version: 00
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress cap_list
       configuration: latency=0
       resources: ioport:d000(size=256) memory:f7900000-f7903fff
       description: Ethernet interface
       product: RTL8111/8168B PCI Express Gigabit Ethernet controller [10EC:8168]
       vendor: Realtek Semiconductor Co., Ltd. [10EC]
       physical id: 0.2
       bus info: pci@0000:04:00.2
       logical name: eth0
       version: 0a
       serial: 00:90:f5:cd:6d:f7
       size: 100Mbit/s
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full firmware=N/A ip= latency=0 link=yes multicast=yes port=MII speed=100Mbit/s
       resources: irq:43 ioport:c000(size=256) memory:f2104000-f2104fff memory:f2100000-f2103fff
  • What is the notebook's manufacturer/model number? Please paste output of lshw -c network.
    – ish
    May 20, 2012 at 2:56
  • The notebook is from a Brazilian local manufacturer - it's an Avell Diamond P110-F1HJ. The output from lshw says the card is unclaimed; I'll update the post with the results.
    – ugopozo
    May 20, 2012 at 3:24
  • Ugopozo: I've added an updated answer with the driver that was recently released as well as a mini-FAQ and steps to build it. Please consider accepting the answer if you think it answers your original question :) Thanks
    – ish
    Jul 18, 2012 at 23:36
  • The askubuntu.com/a/165002/74671 is work, thanks ! Jan 19, 2013 at 16:44

6 Answers 6


Realtek is making the official Linux driver available unofficially (via Dropbox)

Support for the RTL8273AE-BT has been added by Realtek in the 92-series driver, version 0006.0514.2012. For unknown reasons, neither the Windows nor Linux drivers are available on their website (yet). But Realtek tech support has been providing a Dropbox link with the source code/firmware tarball which numerous users have reported as working.

Where do I get it? Is it safe?

  • The driver can be downloaded via this Dropbox link.
  • I can confirm that this file is what it claims to be, with this content listing, provided it has the following MD5 or SHA1 hashes: (which you can verify with md5sum or sha1sum)

    MD5: fd10e9a347c6447f649324d6bdab53de
    SHA1: 1ccd6ae73878d8bf65bd7c0384e333b121606230

How do I build and install the driver on Ubuntu?

  1. Open a terminal with Ctrl+Alt+T.
  2. You'll need to install these packages first to build the driver:

    sudo apt-get install build-essential linux-headers-generic linux-headers-`uname -r`
  3. Paste the below line to download and extract the driver archive in one single step:

    wget -O- http://dl.dropbox.com/u/57056576/DRIVERS/REALTEK/rtl_92ce_92se_92de_8723ae_linux_mac80211_0006.0514.2012.tar.gz | tar -xz
  4. Change to the extracted driver's directory, build and install the driver:

    cd rtl_92ce_92se_92de_8723ae_linux_mac80211_0006.0514.2012
    sudo make install
  5. Test the driver by loading it (this is a one-time step; after you reboot once, the driver should automatically load on every boot):

    sudo modprobe rtl8723e
  • I tested and it indeed works. I was uneasy about installing a driver from a Dropbox anonymous source, as it was linked in other threads, and I even tried to contact Realtek's support directly (to no avail), but your high reputation made me think it was worth a shot. However, is it normal for the Linux driver greatly reduce the wireless working range? I'm getting mediocre ranges with it installed. Do you have any information on whether and how Realtek intends to release updates to this driver? Thanks for your time.
    – ugopozo
    Jul 23, 2012 at 1:56
  • Just want to confirm: this driver, although it works, has severe problems concerning range. I say that because, connecting to the same network, from the same spot, using this driver, shows significantly more instability (to the point of not being able to connect to my work wireless network) than either using the same card on Windows or using a USB dongle on Linux. That's probably the reason why it's not still on Realtek's website; it's not production-ready.
    – ugopozo
    Jul 23, 2012 at 12:53
  • Worked perfectly. Just tar xvf, make, sudo make install and modprobe worked straight away. Thanks so much! :-) Aug 12, 2012 at 8:52
  • 5
    A newer version of the driver, compatible with the 3.5 kernel can be found here liteon.com/UserFiles/driver/Module/Network/WLAN/RTL/…
    – user239558
    Nov 19, 2012 at 16:04
  • Hey I struggle with compiling this source unix.stackexchange.com/questions/74110/… so I found out the latest source is on github.com/lwfinger you may include this in your answer May 9, 2013 at 11:04

Commenting out/removing the IEEE80211_HW_BEACON_FILTER (line 320 in base.c) makes it possible to compile when using the 3.4 kernel. So far I haven't experienced any problems. The card seems to work as it did before, although it might be less power-efficient. I can't guarantee it won't cause any problems, but it's better than nothing.

Well, then here's some new feedback for ya: I did all of the above and got the same compile error and fixed it with your suggestion. Then the driver worked ONCE. After rebooting, no longer it could open any wireless connections. Tried booting into windows 7 and still, no longer it can detect any wireless connections.

I am now convinced this procedure has bricked my wlan adapter - windows still recognizes the device but there is some problem because it no longer senses any wireless connections. I have to use an external linksys adapter because my onboard realtek is gone :/

<<>> Disregard above comment because I was pissed when I wrote that.

UPDATE: I found out that somehow that driver has set my WLAN module's 'Roaming Sensitivity' setting to 'Low', which was causing it to not be able to detect any wireless signal whatsoever. In Windows 7, I went to device manager and changed that setting to 'High' and voilá - it went back alive! phew...

In any case, be aware that this sort of thing might happen to you if you're not careful when following advice from the interwebs. I will think twice before booting into my ubuntu partition again...


I talked with a support guy from Realtek and received the very same files hosted on Dropbox submitted by another user on this question. I compiled the drivers as the readme instructed and it worked, you might need to copy the 8723* firmware files into the rtlwifi folder.

It should be said however that this solution is not perfect, I have some pretty shaky connection to WEP APs. Also this driver support up to and including kernel 3.3.

The 3.4 kernel have removed some calls in the mac80211 module that this driver needs to compile and thus exits with an error and can not compile. This is not an issue for ubuntu right now, but it means you can't install the driver on a up-to-date Fedora 17 or any other distro using the 3.4+ kernel - including upcoming versions of Ubuntu.

See http://article.gmane.org/gmane.linux.kernel.wireless.general/84114/match=ieee80211_hw_beacon_filter for information about the changes.

  • 1
    I can confirm that the driver does not work on the 3.5 kernel, even after removing the offending line so that it compiles. A new solution to this problem is needed as as it currently stands, 12.10 is not supported.
    – user239558
    Oct 27, 2012 at 14:13
  • Update to the above, the following driver works for me on 3.5 liteon.com/UserFiles/driver/Module/Network/WLAN/RTL/…
    – user239558
    Nov 19, 2012 at 16:05

Well, I found a "solution". It's not a proper one: I just bought a wireless USB dongle (with the RTL8188CUS chipset) which, after installing the drivers, is promptly recognized.

To anyone browsing this thread with the same problem, I'd say the best solution is to wait for Realtek to release the official driver for 8723 on its website. They usually do that, and it's symptomatic that not even the Windows drivers are available on the official website (I guess this indicates this is a fairly new chipset).

I'll keep an eye on the website, and when the driver is released, I'll update this answer with specific instructions for installation.


please download this two files. I received them from Realtek. http://dl.dropbox.com/u/57056576/DRIVERS/REALTEK/8723AE_8723AU_Linux_support_0419.tar.gz


  • How did you receive them? Is it possible for people to obtain them from Realtek's website? People may not want to download files like this from Dropbox, for security reasons. (There's no way to know if these files really are what they say they are!) Jun 23, 2012 at 23:21
  • Hello! In order to get these drivers I had to write a Realtek. They sent them to me by mail. I have no idea why they did not put them on their website.
    – user56800
    Dec 14, 2012 at 22:30
  • May 15, 2013, still nothing on the Realtek web site. Ubuntu 13.04 did incl the 8723 driver. Use updated tarball if you need to compile: rtl_92ce_92se_92de_8723ae_linux_mac80211_0007.0809.2012.tar.gz
    – ubfan1
    May 14, 2013 at 17:00

Thank you. I had the same problem and downloading and building the two .gz files made my card work!

For some reason the install script didn't copy the firmware correctly, so I had to do it manually. I moved rtl8723fw.bin and rtl8723fw_B.bin from the rtlwifi folder in the source directory to /lib/firmware/rtlwifi/, rebooted and it worked.

I'm sure it won't be long before the driver is added to the Linux kernel though.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .