I use Lubuntu on one desktop and Ubuntu on a laptop. Dropbox is my main cloud syncing service but I have created an Ubuntu One SSO account in order to backup my home folders.

At first, I was not able to use Ubuntu One on Lubuntu - after installing it from synaptics, when I tried to open it, nothing happens except opening a blank terminal window. I had to do this tweak to make it work on Lubuntu: http://ubuntuforums.org/showthread.php?t=1949533

After I done this, the Lubuntu bar icons became distinct and logon screen got somewhat misconfigured, having some non-existing usernames in there, but it still works fine so I didn't care much about it.

Now I can open Ubuntu One client and sync files with the cloud service, but I have no option in context menu to sync any other folder in Lubuntu. It only works if I add the files and folders to Ubuntu One parent folder.

Worse than that, it is causing a failure with Deja Dup backup of my home folder. Here it is what comes up on Deja Dup dialog every time I start Lubuntu:

Traceback (most recent call last):
  File "/usr/bin/duplicity", line 1403, in <module>
  File "/usr/bin/duplicity", line 1396, in with_tempdir
  File "/usr/bin/duplicity", line 1247, in main
    action = commandline.ProcessCommandLine(sys.argv[1:])
  File "/usr/lib/python2.7/dist-packages/duplicity/commandline.py", line 999, in ProcessCommandLine
    globals.backend = backend.get_backend(args[0])
  File "/usr/lib/python2.7/dist-packages/duplicity/backend.py", line 158, in get_backend
    return _backends[pu.scheme](pu)
  File "/usr/lib/python2.7/dist-packages/duplicity/backends/u1backend.py", line 74, in __init__
  File "/usr/lib/python2.7/dist-packages/duplicity/backend.py", line 323, in iterate
    return fn(*args, **kwargs)
  File "/usr/lib/python2.7/dist-packages/duplicity/backends/u1backend.py", line 160, in create_volume
    import ubuntuone.couch.auth as auth
ImportError: No module named couch.auth

Can anyone help me with this? How can I make Ubuntu One sync other folders on Lubuntu? And how to solve this error with Deja Dup backup?

Any help would be much appreciated.

  • 1
    That module should be provided by the ubuntuone-couch package. It is included in the instructions for the forum thread, but could you verify that it is installed? May 20, 2012 at 1:27
  • @JamesHenstridge Yes I had it installed but after removing it completely and reinstall the ubuntuone-couch package, everything seems to be fine now. By the way, this only happened after I upgraded from 11.10 to 12.04 last month. Thanks for the tip.
    – Neptunno
    May 20, 2012 at 1:49
  • 1
    Perhaps you had some half-installed packages? That can happen if you're trying to install .deb packages directly and don't fulfill the dependencies, rather than going through apt-get. May 20, 2012 at 10:18
  • Well I installed Ubuntu One primarily from software center, it worked fine until the upgrade to 12.04, I'm not sure what happened with that particular package. Anyway I'll be careful from now on about dependencies as you said. Thanks for the help.
    – Neptunno
    May 20, 2012 at 14:38
  • 2
    The deja-dup package does have a Recommends on ubuntuone-couch, I believe, and that package is installed by default. So the only way it wouldn't be there is if it was removed for some reason, either by user intervention, or because some dependency confusion during upgrade resulted in it being uninstalled.
    – dobey
    May 20, 2012 at 16:21

1 Answer 1


The missing module is provided by the ubuntuone-couch package. Just use synaptics package manager to install it.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .