I have a PS4 DualShock controller, and Ubuntu 20.04. I have Steam devices installed, but Steam says:

No controllers detected.

It used to work and I don't know what made it stop working. I don't think I've updated recently. The computer can detect the controller, too, but Steam can't. I've tried both wired and wireless methods. I've tried different wires, none of which works. I have also tried this method: https://steamcommunity.com/app/221410/discussions/0/1693795812304458372/

However, I tried a different controller and it works. So why can't I get mine working?

Thank you in advance for your help.

  • Does it work with other computers/consoles? Mar 6, 2022 at 13:14

1 Answer 1


Was scouring the internets yessterday after dealing with that exact problem and found this link hope it works for ya https://steamcommunity.com/app/221410/discussions/0/2930112548442481325

  • Please could you put the steps into your answer, not just a link? Then, if the link breaks, your answer is still useful. Thank you!
    – Will
    Mar 7 at 22:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.