0

MobaXterm v21.1 connects to Ubuntu 20.04.3 LTS server through SSH disconnects all the time after short idle time, with this error: network error: software caused connection abort. I tried everything written here: https://programmerah.com/mobaxterm-connects-to-ubuntu-server-through-ssh-network-error-software-caused-connection-abort-43897/

  • changed setting of Mobaextrem to keep alive
  • edited /etc/ssh/sshd_config
    • TCPKeepAlive yes
    • ClientAliveInterval 60

I even left a top command running in the terminal, didn't help.

Is there an option that the disconnect is coming from the Ubuntu side ? Any idea how to solve it will be much appreciated.

** edit **

checking /var/log/auth.log

I see:

Mar  3 01:12:09 COSDEVVIS12 sshd[1529012]: Timeout, client not responding from user naomi <myip> port 59737

Beginning of /etc/ssh/sshd_config is:

#       $OpenBSD: sshd_config,v 1.103 2018/04/09 20:41:22 tj Exp $

# This is the sshd server system-wide configuration file.  See
# sshd_config(5) for more information.
/etc/ssh/sshd_config.d/*.conf

I run

/usr/sbin/sshd -ddd -p 10022

I get:

/etc/ssh/sshd_config: line 5: Bad configuration option: /etc/ssh/sshd_config.d/*.conf

...

/etc/ssh/sshd_config: terminating, 1 bad configuration options

1 Answer 1

0

How long does it take to disconnect when you are idle?

Try changing your ClientAliveInterval to something smaller, like 5 (this will send the null packet every 5 seconds, instead of every minute as you have set now).

4
  • I don't know exactly, but less then 2 hours. I'm working with jupyter notebook, running on chrome on my local computer. I train dl networks, and it gets disconnected in the middle of training. I will try to change ClientAliveInterval as you suggested. Mar 2 at 9:37
  • changing ClientAliveInterval to 5, don't solve the problem. Mar 2 at 12:45
  • It could be that the problem lies in the connection reliability on your side. Try this -- connect to your Ubuntu Server in MobaXterm, then open a command prompt in Windows and ping the server for awhile ping server.ip.here -t and see if you get any time-outs.
    – Maik
    Mar 2 at 14:33
  • 1
    The beginning of your /etc/ssh/sshd_config file is missing "Include" --- Include /etc/ssh/sshd_config.d/*.conf
    – Maik
    Mar 3 at 12:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.