I've just bought an ARCAM rPAC external USB sound device, and after a lot of hours spent, I just can't get it to work on Ubuntu 12.04 64bit setup.

It uses a TI PCM5102 DAC chipset with Asynchronous USB. I don't think there's a need for a special driver for it, as the rPAC works fine on Windows/Mac OS X using the generic USB driver.

When I plug it in, I find the following in syslog:

May 19 19:31:11 UBUNTUBOX kernel: [  179.096403] usb 1-1.2: new full-speed USB device number 5 using ehci_hcd
May 19 19:31:14 UBUNTUBOX pulseaudio[1678]: [pulseaudio] alsa-util.c: Unable to load mixer: Invalid argument
May 19 19:31:14 UBUNTUBOX kernel: [  182.207155] 5:1:1: usb_set_interface failed

There are loads of those usb_set_interface failed lines. Later on, I get the following when I use aplay -l to query it, I get more:

May 19 19:33:06 UBUNTUBOX kernel: [  294.021946] 6:1:1: usb_set_interface failed
May 19 19:33:06 UBUNTUBOX pulseaudio[2264]: [pulseaudio] module-alsa-card.c: Failed to find a working profile.
May 19 19:33:06 UBUNTUBOX pulseaudio[2264]: [pulseaudio] module.c: Failed to load module "module-alsa-card" (argument: "device_id="1" name="usb-ARCAM_ARCAM_USB_Audio_1.0_0000-00-A10" card_name="alsa_card.usb-ARCAM_ARCAM_USB_Audio_1.0_0000-00-A10" namereg_fail=false tsched=yes ignore_dB=no deferred_volume=yes card_properties="module-udev-detect.discovered=1""): initialization failed.
May 19 19:33:06 UBUNTUBOX pulseaudio[2264]: [pulseaudio] module-udev-detect.c: Tried to configure /devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.2/1-1.2:1.0/sound/card1 (alsa_card.usb-ARCAM_ARCAM_USB_Audio_1.0_0000-00-A10) more often than 5 times in 10s

Running lsusb gives the following line for the rPAC:

Bus 001 Device 007: ID 25c4:0003

Typing aplay -l gives the following -- see card 1 below:

card 0: PCH [HDA Intel PCH], device 0: CONEXANT Analog [CONEXANT Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: A10 [ARCAM USB Audio 1.0], device 0: USB Audio [USB Audio]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

So the rPAC device is obviously alive and recognized by some part of Ubuntu. Furthermore, the LED on the rPAC turns green from red when connected, indicating that it's activated.

So far, I've tried adding the following line to /lib/udev/rules.d so that libmtp (I'm on libmtp9, by the way) might recognize it:

ATTR{idVendor}=="25c4", ATTR{idProduct}=="0003", SYMLINK+="libmtp-%k", MODE="660", GROUP="audio", ENV{ID_MTP_DEVICE}="1", ENV{ID_MEDIA_PLAYER}="1"

I also tried changing /usr/share/alsa/alsa.conf to give it a specific hardware slot (slot 1). But firstly, I get the following error:

cannot find the slot for index 1 (range 0-29), error: -16

and secondly, the rPAC light remains at red. So I've backed out my changes to alsa.conf.

If anyone's got any bright ideas, I'd very much appreciate it! I'm spending too much time banging my head against a brick wall!




to clarify as of 25/05/2012

The rPAC DAC (class I only) is not compatible with the current Linux kernel.

We have updated our FAQ, web and product info to make this clear.

Apologies for the confusion, I can help you get a refund if necessary.

Cheers Robert

| improve this answer | |

I've been through similar issues on my linux distro. To playback music I use MPD and GMPC with bit perfect configuration, i.e. in the mpd.conf file I have

audio_output {
    type        "alsa"
    name        "ARCAM USB Audio 1.0"
    device      "hw:1,0"    # optional

when trying to play a song, GMPC tells it cannot open the playback device or something similar. I also got the "usb_set_interface failed" errors in syslog (running dmesg). After various online searches, trials and errors, I finally decided to uninstall completely PulseAudio. After rebooting, everything is working now (red light while not playing, green light while playing, as in Win7... and great sound!).

I made further checks while playing 96kHz FLAC running the following command

cat /proc/asound/card1/stream0

ARCAM ARCAM USB Audio 1.0 at usb-0000:00:1d.0-1, full speed : USB Audio

  Status: Running
    Interface = 1
    Altset = 1
    URBs = 3 [ 8 8 8 ]
    Packet Size = 582
    Momentary freq = 96000 Hz (0x60.0000)
    Feedback Format = 10.14
  Interface 1
    Altset 1
    Format: S24_3LE
    Channels: 2
    Endpoint: 1 OUT (ASYNC)
    Rates: 44100, 48000, 88200, 96000

It seems everything is working well since the momentary freq is 96kHz as expected and the format (S24_3LE) says the information is passed directly to the DAC (as I understood from my online searches).

Hope it helps!



| improve this answer | |

I've been through all the same things as you have, and also have had no luck.

I contacted the place from where I bought the rPAC, who then contacted Arcam, who stated that the device isn't supported on Linux (the documentation, you may note states that it works on 'PCs'...). Undeterred, I asked Arcam directly on Twitter (they didn't bother to respond to an email that I sent on the 4th May, which was nice of them), who contradicted their support people, and said that it does work (on Linux), and the person responding thought that they were running Fedora; I tried that too, to no avail.

You could always ask them (Twitter/email) and see how they respond. I'd certainly be interested to see.

EDIT: Perhaps ask them to comment on this question?



| improve this answer | |
  • Thanks, James. I pointed ARCAM to this page on askubuntu.com, but they haven't yet got back to me. There is a FAQ at on arcam.co.uk/extranethome/tor which offers some guidance on how to set up the rPAC under Linux, but their testing appears to have all been done in 2010 on a version of Linux they don't specify! Great! The fact that other USB audio devices work fine with Linux without any fuss seems to suggest that there is some sort of issue with the rPAC under Ubuntu. As for me, I've drawn a blank with the rPAC, and sent it back to my dealer for a refund. Thanks James. – James East May 22 '12 at 17:46

It's an old post but I am sure there are people liek me that will benefit from my findings on the rPac and Linux.

It looks like the rPac starts as a usd 1.0 device by default. Some kernels accept that but most of them don't.

To force the rPac starting as a usb 2.0 device press both volume buttons while powering it up. You'll get the amber LED which also means the device is on mute. Then, press one of the volume buttons. At this point, you should be ready to play music through your rPac.

You'll see the following in usb 1.0

cat /proc/asound/card1/stream0

ARCAM ARCAM USB Audio 1.0 at usb-0000:00:1d.0-1, full speed : USB Audio

But in usb 2.0 mode you'll see the following

cat /proc/asound/card1/stream0

ARCAM ARCAM USB Audio 2.0 at usb-0000:00:1d.0-1, full speed : USB Audio

Note the 2.0... and the sound card name will change to from A10 to A20

I tested the procedure on Ubuntu 13.10 and debian 7 and it works.


| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.