1

This question has been asked many times by many users, but there is no definate answer and it still remains an open bug even after all this time. This appears to be a problem with Ubuntu on some selected number of laptops. I'm using Ubuntu 20.04 for almost 2 years now, but this problem arose in last 1 or 2 months. Most solutions I have read online regarding this are to run an automated script to lower the brightness on every startup. But that is not a native solution. I would like a permanent fix to this because this bug didn't exist for me before 1-2 months ago. My other laptop which is also running 20.04 doesn't have this issue. I'm running the latest version of Ubuntu 20.04 on Dell 5559 laptop with an SSD.

6
  • Both have the same video card and same driver?
    – David
    Feb 26, 2022 at 16:22
  • Both are Dell laptops, but have different hardwares. I have mentioned the one that is having the issue.
    – Vin Raghav
    Feb 26, 2022 at 16:25
  • You pointed out the other one does not have this issue so yes the hardware differences especially the video card do matter.
    – David
    Feb 26, 2022 at 16:26
  • Please see my answer. If it's helpful, please remember to accept it by clicking on the checkmark icon that appears just to the left of my answer. Thanks!
    – heynnema
    Feb 26, 2022 at 16:54
  • Does this answer your question? Full brightness on startup after the recent update
    – heynnema
    Feb 26, 2022 at 17:06

1 Answer 1

0

The problem is that there's a process that runs at boot, and also at shutdown, that tries to restore/save backlight settings. One some configurations the restore happens incorrectly, and can cause the brightness problem that you see. Here we will add a minor kernel option so that this process doesn't restore an invalid brightness setting.

man systemd-backlight

Rather than using the script that you found, (that I probably wrote), do this:

Edit /etc/default/grub:

sudo -H gedit /etc/default/grub

Locate the line that looks like:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

And change it to:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash systemd.restore_state=0"

sudo update-grub

Set your brightness to the desired level.

reboot

4
  • Could you explain what this will do? Will this impact just the brightness state or everything?
    – Vin Raghav
    Feb 27, 2022 at 4:33
  • @VinRaghav I updated my answer. It's a harmless mod that only effects the brightness being restored to an incorrect value at boot time.
    – heynnema
    Feb 27, 2022 at 8:02
  • This change won't only affect the brightness, but everything.
    – Vin Raghav
    Mar 5, 2022 at 16:20
  • @VinRaghav How do you figure? It only effects the backlight restore at boot time. Did you try it?
    – heynnema
    Mar 5, 2022 at 17:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.