1

Sound is not working on my Asus Vivobook Pro 14X (Ryzen 9 and NVIDIA GEFORCE RTX3050 STUDIO).

Speaker by harman/kardon;Chip: Realtek ALC294


cat /proc/asound/cards

 0 [Generic        ]: HDA-Intel - HD-Audio Generic
                      HD-Audio Generic at 0xfc5c8000 irq 102

 1 [Generic_1      ]: HDA-Intel - HD-Audio Generic
                      HD-Audio Generic at 0xfc5c0000 irq 103

uname -ro    
5.13.0-30-generic GNU/Linux

   *-cpu
        description: CPU
        product: AMD Ryzen 9 5900HX with Radeon Graphics

   *-multimedia:2
        description: Audio device
        product: Family 17h (Models 10h-1fh) HD Audio Controller
        vendor: Advanced Micro Devices, Inc. [AMD]
        physical id: 0.6
        bus info: pci@0000:04:00.6
        version: 00
        width: 32 bits
        clock: 33MHz
        capabilities: pm pciexpress msi bus_master cap_list
        configuration: driver=snd_hda_intel latency=0
        resources: irq:103 memory:fc5c0000-fc5c7fff

Headphones are also not working. Sound is working fine on Windows 11 in my dual booting system. Please help me to fix this issue.

1
  • 1
    Try the latest mainline kernel.
    – Pilot6
    Feb 23 at 8:08

1 Answer 1

1

After a lot of research through the internet, I got a temporary solution to fix this issue.

sudo #!/bin/bash
sudo hda-verb /dev/snd/hwC0D0 0x20 0x500 0x1b
sudo hda-verb /dev/snd/hwC0D0 0x20 0x477 0x4a4b
sudo hda-verb /dev/snd/hwC0D0 0x20 0x500 0xf
sudo hda-verb /dev/snd/hwC0D0 0x20 0x477 0x74

Run this script then use the power button to shutdown your system(The normal power Off/restart/ with sudo privilege also didn't fix). I don't know how but this fixed my system. This will solve the issue until you boot to windows again, then you have to redo the process. I don't know if there is any other methods available to fix this issue permanently, but this is the only method that worked for me after trying multiple methods.

2
  • I have the same problem with a similar notebook, Vivobook m7400q. Ryzen and rtx3050ti Your workaround works but it's unusable in the everyday work. Did you find a more stable solution? I'm struggling with this problem and every "solution" I tried didn't work.
    – Mangus78
    Jul 30 at 23:06
  • (Unconfirmed) link to the Bugzilla on this issue from new contributor @sf6 in an "answer" (that will likely be deleted as not-an-answer). If a mod can convert that info to a comment on behalf of the user, I'll hope they'll delete mine at the same time ;-). Or when @sf6 gains enough rep to leave a comment on their own, they are welcome to do so and Flag this/mine as "no longer needed". Dec 5 at 20:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.