I just installed Ubuntu 12.04 AMD64 on a new (empty) hard disk (because the previous crashed)

Since I am quite familiar with Debian, I created two accounts with the adduser command.

Since I am also having an NFSv3 file system, I explictly gave user ids when creating them (for simplicity, I keep the same user id on the home server, running Debian; the user names contain digits; I'm not using LDAP), e.g.

  # grep bethy /etc/passwd
  bethy46:x:501:501:Bethy XXX,,,06123456:/home/bethy:/bin/bash
  # grep bethy /etc/group
  # grep bethy /etc/shadow

Of course /home/bethy exists

The actual user name is slightly different, and I am not showing the real entries (for obvious privacy reasons)

However, these users don't appear at graphical login prompt (lightdm).

And they exist in the system, they have entries in /etc/passwd & /etc/shadow and I (partly) restored their /home

I've got no specific user config under /etc/lightdm ; file /etc/lightdm/users.conf mentions

 # NOTE: If you have AccountsService installed on your system, then LightDM
 # will use this instead and these settings will be ignored

but I have no idea of how to deal with AccountsService thru the command line

As you probably guessed, I really dislike doing administrative tasks thru a graphical interface; I much prefer the command line

What did I do wrong? How can a user entry not appear in lightdm graphical login? (I need to have my wife's user entry apparent for graphical login).

I am not asking how to hide a user, but how to show it in lightdm graphical prompt


As I have been told in comments by Nirmik and by Enzotib, lightdm probably don't show any users of uid less than 1024. So I changed all the uid to be more than 8200 (including on the Debian NFS server) and this made all the users visible at the graphical prompt.

It is a pain that such a threshold is not really documented.

  • In my /etc/lightdm/users.conf I have the line minimum-uid=500, that seems compatible with your user id.
    – enzotib
    May 19, 2012 at 16:59
  • @Rinzwind: I tested what the OP says, with adduser --uid 501 some-name, and the user in not shown in lightdm. I think lightdm follows AccountService prescriptions that are probably set to 1000, but I don't know how to solve. I think the question should not be closed.
    – enzotib
    May 19, 2012 at 17:30
  • 1
    I dont remember exactly where i have read it but lightdm does not display a user if the uid is below 1000.
    – Nirmik
    May 19, 2012 at 17:56
  • @BasileStarynkevitch Less than 1024? Most Ubuntu systems only have UID's lower than 1024. This would be breaking almost everyone's Ubuntu system, if that were the case. Do you mean 1000, as Nirmik suggested? Jun 1, 2012 at 20:12

4 Answers 4


If there is AccountService running, the file /etc/lightdm/users.conf is ignored. In such case, you can set minimal UID by changing value of attribute UID_MIN in file /etc/login.defs.

  • This is the correct answer. What happens is that that AccountService thingy is a kind of wrapper for useradd, usermod and userdel so it reads the information from login.defs which is the file that stores configuration for the useradd command and for logins.
    – devius
    Jun 10, 2012 at 22:28

Generally the uid 100~999 are reserved for system accounts and those should not be used as normal user's uid, as described by useradd manual

Values between 0 and 999 are typically reserved for system accounts.

Hence, using uid below 1000 causes lightdm not to show them. Try changing the uid value of the user above 999. (actually above 1000 because, the first user's uid which is you is 1000) For example, to set the uid 1004 use this command:

sudo usermod --uid 1004 bethy46

This will change the uid of user bethy46 to 1004 and thus showing in the lightdm user prompt.

To know the uid of a user named user use this command:

id -u user

I had exactly the same problem. My work around was to disallow lightdm to display valid usernames but rather to ask the user to type in her username. I didn't like that usernames were displayed anyway.

Happy i was until i noticed that SSHd also suffers from the same problem. I am logged in as xyz and yet when i try to ssh into my PC as xyz, i get a "Permission denied, please try again." And when i check the file /var/log/auth.log i find the following:

Jun  1 01:18:27 mypc sshd[17357]: input_userauth_request: invalid user xyz [preauth]

Jun  1 01:18:32 mypc sshd[17357]: error: Could not get shadow information for NOUSER

Jun  1 01:18:32 mypc sshd[17357]: Failed password for invalid user xyz from port 57492 ssh2

Jun  1 01:18:36 mypc sshd[17357]: Failed password for invalid user xyz from port 57492 ssh2

Jun  1 01:18:38 mypc sshd[17357]: Connection closed by [preauth]

And yet connecting by SSH using the account with which i installed Ubuntu 12.04 works just fine.

The GUI to add new users is over-simplistic. I don't want to have to chown and chgrp all my data. What is the GUI doing that i've left out when editing passwd, group, shadow.


This is an old question but comes up when you search for a way to enable users to show up in Debian. The way I've found to do this in Debian is to create a file in /etc/lightdm/lightdm.conf.d called:


Use root privileges. I use nano but you can do this with gedit or a similar text editor.

mkdir /etc/lightdm/lightdm.conf.d
nano /etc/lightdm/lightdm.conf.d/01_my.conf

Add the following:


Save your changes, exit and reboot or logout. Now your computer should show your user.

I found this here.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .