0

Whenever I play audio from various apps, like Spotify, or any browser (I checked Firefox and Tor), the computer starts beeping after couple of minutes. The beeping stops only when I stop playback. I also checked if it appears when I plug in 3.5 mm jack headphones and it does. Before 21.10 I was using 20.04 LTS and there were no audio issues there. There is a similar question raised in regards to ASUS T102HA, but since I am a new user I am not allowed to add comments there. I wanted to run sudo sensors-detect according to what was suggested there, but the app started to ask me about loading various kernel modules, so at some point I just opened built in resources monitor. Please see the screenshot attached. CPU load was around 50% when the beeping started and it raised to 100% until I killed the process. My machine - ASUS T100TA

4

3 Answers 3

0

I had the same with my last upgrade. Downloading https://github.com/thesofproject/sof-bin/archive/refs/heads/main.zip installing v1.9-rc1 seems to have fixed it for me. For whatever reason 1.9 leads to buzzing but rc1 doesn't.

0

I didn't manage to fix this issue under Ubuntu 21.10, so I wanted to see if the new LTS release fixes this bug, as I didn't have that problem on 20.04. Current LTS release actually completely destroyed sound output - none audio drivers were detected, reinstalling Alsa and Pulseaudio didn't make any effect. However that was good, because it directed me towards looking for missing audio drivers fix and I finally found this: Heikomat Github

I ran the script wget -qO- https://gist.github.com/heikomat/3fe272431b44b580c933bfb901a92257/raw | bash and it completely fixed my audio settings. I am listening to like the third song in a row while typing this post and everything works pretty well. Heikomat, if you are here on Ask Ubuntu, then I am grateful for your great work and huge help.

0

Here's github issue on this problem: https://github.com/thesofproject/sof/issues/3868.

To summarize, adding options snd_sof sof_debug=1 to the /etc/modprobe.d/alsa-base.conf should help.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.