Situation: Clean install of 12.04 and of HPLIP 3.12.4. The printer is detected and installed correctly. The problem starts afterwards.

Whenever entering the session, HPLIP starts and is shown on the menu bar (in 11.10, HPLIP didn't show until the printer was plugged in). When plugging in the printer, HPLIP gives a 'Devise communication error', and won't print.

Workaround: After much fooling around, I've found that I can uninstal the printer, then plug the printer in, HPLIP detects it and voilá, it'll print.

Sometimes, the program will show a message HPLIP already mounted, so that might be part of the problem.

Also, HPLIP creates a 'system problem', but the report never goes anywhere...

I'd like to be able to troubleshoot this problem, or should I just wait until a new version of HPLIP is released. I think this problem affects more people.

Edit: Forgot to mention. When plugging the printer in, HPLIP will add another printer instead of recognising that the printer is already installed.

enter image description here enter image description here enter image description here

Status update: Solved The problem was the HPLIP download. I downloaded version 3.12.4, but the correct version is 3.12.2... as indicated by HPLIP... but the link goes to the next version.

I uninstalled everything. Installed 3.12.2. In the end it all works.


From your question you are using the HPLIP version downloaded and installed directly from HP themselves and not from the repository version in 12.04.

The repository version is v3.12.2.

This is likely to be a bug with the HP version -you should perhaps report this as a bug-report to HP directly themselves to get it fixed.

My suggestion would be to uninstall the HP version of HPLIP and then install the repository version.


To uninstall the HP version of HPLIP:

Change to the directory you extracted the tar-ball with, for example

cd ~/Downloads/hplip-3.14
sudo make uninstall

Now do final cleanups:

sudo rm -rf /usr/share/hplip
sudo rm -rf /etc/hp
sudo rm -rf ~/.hplip
sudo rm -rf /var/lib/hp

Install HPLIP from the repository

You can use the Software Center to do this (search for HPLIP) or from the command line:

sudo apt-get install hplip
  • There you go, this worked for me, cheers! – GUI Junkie May 27 '12 at 10:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.