0

I have installed Ubuntu 21.10, 21.04, Kubuntu 21.10, 21.04, Fedora 34/35 and my Intel Wireless 8265 card will not work. I have updated the ucode and tested it without success. If install Windows 10 or 11 it works fine. I am not dual booting. Here are some logs:

here is the dmesg error, I see I have a nvme error as well,

[ 443.026431] Intel(R) Wireless WiFi driver for Linux
[ 443.027906] iwlwifi 0000:02:00.0: loaded firmware version 36.ca7b901d.0 8265-36.ucode op_mode iwlmvm
[ 443.050061] iwlwifi 0000:02:00.0: Detected Intel(R) Dual Band Wireless AC 8265, REV=0x230
[ 444.268308] iwlwifi 0000:02:00.0: Couldn't prepare the card
[ 444.268322] iwlwifi 0000:02:00.0: Error while preparing HW: -110
[ 444.338527] iwlwifi 0000:02:00.0: Master Disable Timed Out, 100 usec
[ 444.544681] pcieport 0000:00:1d.0: AER: Corrected error received: 0000:04:00.0
[ 444.544700] nvme 0000:04:00.0: PCIe Bus Error: severity=Corrected, type=Physical Layer, (Receiver ID)
[ 444.544706] nvme 0000:04:00.0: device [144d:a804] error status/mask=00000001/00006000
[ 444.544714] nvme 0000:04:00.0: [ 0] RxErr

and

When I run lshw -C network I get:

*-network
description: Network controller
product: Wireless 8265 / 8275
vendor: Intel Corporation
physical id: 0
bus info: pci@0000:02:00.0
version: 78
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress bus_master cap_list
configuration: driver=iwlwifi latency=0
resources: irq:147 memory:edc00000-edc01fff
2
  • Shut down Windows properly. It is normal for a dual boot.
    – Pilot6
    Commented Feb 12, 2022 at 8:59
  • This is a clean installation of Ubuntu, Kubuntu, Fedora and i have now tried Red Hat. I reinstalled windows and did everything I read about how to fix this, and then installed Linux, clean install, and no Windows, I still get the error. Commented Feb 14, 2022 at 19:48

1 Answer 1

0

In my case, i have a ssd with Windows 10 and another with Ubuntu. I had to turn off fast startup for Windows 10 (https://www.computerhope.com/issues/ch001762.htm). Basically: Control Panel -> Power Options -> System Settings -> Shutdown settings -> Turn on fast startup << uncheck this. After this, wifi on Ubuntu worked.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .