Thanks for this great initiative. I have a reliance netconnect datacard (in India) which I am trying to setup in Ubuntu 10.04 (Lucid).

I have tried it with the Network manager to create a new Wireless Broadband connection. I have tried all the variations of the protocols etc, but no luck getting it to work. I then installed wvdial and gnome-ppp, using which I am able to connect to the internet quite reliably.

I read on many forums that people have been able to connect to Reliance Netconnect using the Network Manager directly. If anyone has been able to do this, could you please let me know what setting you used etc? My modem is Huawei, Model EC168C.

Now, my next problem/question: I want to share the internet connection using what is known as "ad-hoc (computer-to-computer) connection" in Windows. Does Ubuntu support a similar feature? Any tips to do this, and/or links to guides that work would be great!

Also, in order to make this work, do I need to have the connection working via "Network Manager" or would it work even if I connected using wvdial?

Thanks a lot for your answers and help !! Do let me know if any more info is needed.

Cheers, Maha

2 Answers 2


Maha, I cannot help you with the Reliance problem, however I recently setup my laptop to share its internet connection via adhoc wireless. You cannot share a wifi internet connection because you are already utilizing your wireless device but you can share a wired connection, aircard or usb tether connection.

  1. Confirm that dnsmasq-base is installed and install the dhcp3-server package.

  2. Left click on network manager, select "Create New Wireless Network". Give it a name, add your desired security. Click Create.

  3. Use network manager to connect to the newly created network and you are sharing your internet connection.

Good luck! Ray

  • Thanks Ray. That's much easier than I had expected. I managed to do this. However, my brother went out of town for the weekend so I won't be able to test it out until Monday. I will keep you posted once I test it out :) Many thanks for the tip! -Maha
    – magesha
    Aug 7, 2010 at 18:07

I have a Tata Indicom Photon+ with Huawei E1261. I had to install usb-modswitch and usb-modswitch-data to get the Network Manager to detect it. I am not sure it will work with Huawei EC168C, but you might want to check it out.

Here is the link: http://digitizor.com/2010/06/28/how-to-use-tata-photon-plus-in-ubuntu-10-04-lucid-lynx/ (Disclaimer: My blog)

  • Hi Ricky, Thanks for the answer! I tried it out. I think for my device, I should use it's product ID from lsusb, which is 1412 as against 140b you had mentioned. Now, the network manager detects the device and is able to create the connection but still not able to connect. Keeps trying and then fails. Is there a command line way to do the same? If so, I could run that and post the results here. If this could be made to work, that would be so cool! Thanks, Maha
    – magesha
    Aug 7, 2010 at 18:03
  • I am not sure what could be the problem. It should be able to connect if the network manager can detect it. Sorry, I don't know how to do it through the command line. I am not much of a commandline ninja.
    – ricky
    Aug 8, 2010 at 17:13

Not the answer you're looking for? Browse other questions tagged or ask your own question.