I have a Dell Inspiron 1520, which has the Dell Wireless 1390 card (based on the BCM4311 chipset). During installation, Ubuntu 12.04 detected the device and installed the Broadcom STA driver. However, Unity is not showing an icon for the wireless device, so I am unable to connect to any networks. Any ideas what I need to do to get this working?

Edit: lspci -v gives the following info

0c:00.0 Network controller: Broadcom Corporation BCM4311 802.11b/g WLAN (rev 01)
        Subsystem: Dell Wireless 1390 WLAN Mini-Card
        Flags: bus master, fast devsel, latency 0, IRQ 17
        Memory at fe8fc000 (32-bit, non-prefetchable) [size=16K]
        Capabilities: <access denied>
        Kernel driver in use: b43-pci-bridge
        Kernel modules: wl, ssb

/proc/net/dev does not contain any entries for the device, however (it just has lo and eth0 listed).

  • I'm talking about the icon that's second from the right in this image: 3.bp.blogspot.com/-0Hhy--CG_rk/T5r7lIxbIzI/AAAAAAAAAvo/… – Jules May 19 '12 at 1:32
  • Are you sure that you activated your Broadcom STA driver?. It needs to have a green icon next to your driver name. – Robert Smith May 19 '12 at 1:52
  • The additional drivers application shows a green icon and says it is "activated and currently in use". I have no options for wireless networks in the networks menu, only for my wired network. – Jules May 19 '12 at 2:03
  • @Jules In Network Indicator menu click on edit connections and see if it's listed there? sometimes connections don't appear in menu, It's probably a bug. – Basharat Sialvi May 19 '12 at 2:10
  • No, the wireless section of the connection editing dialog is empty. – Jules May 19 '12 at 8:42

My problem appears to be that in a machine with both a BCM43xx wireless and BCM44xx wired connection, the driver for the wired connection requires the generic 'ssb' module, which grabs the resources needed by both, expecting the final drivers to cooperate with it (?). Unfortunately, broadcom's 'wl' driver (which is the driver I had installed) does not cooperate in the way it expects; only the open-source 'b43' driver is capable of doing this.

This bug seems to be related: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/197558

A workaround of the same general kind as the one proposed in comment #4 of that bug would presumably have worked for me, but simpler was to switch to using the 'b43' driver rather than 'wl'. To that end, I blacklisted 'wl'. Once that was done, I added 'b43' to /etc/modules, and the 'b43' driver then loaded automatically at startup, and everything worked smoothly.

| improve this answer | |

Don't know if you're still looking for an answer but the answer here...

How to make my Dell 1390 wlan minicard work

...fixed it for me in a new 12.04 LTS installation on an Inspiron 1520 with the 1390 WLAN card.

Here are the important commands...

sudo apt-get update
sudo apt-get install firmware-b43-installer
sudo apt-get remove bcmwl-kernel-source

...which worked perfectly for me.

Hope this helps.

| improve this answer | |

The 3 steps in answer #2 worked for me on my Dell Inspiron 6400 (similar to the 1520) for Ubuntu 16.04 LTS, but initially after installing Ubuntu, neither the wired or wireless interfaces would work - so I couldn't update using the commands provided. The solution was to remove the incorrect driver causing the network conflict which I found here: Ubuntu 12.04 Dell 6400 no network

To summarize, the three commands to get wired network connectivity was:

sudo apt-get remove --purge bcmwl-kernel-source
sudo modprobe b44

Then I follow the commands in answer #2 and networking (wired and wireless) worked!

| improve this answer | |
  • Hi, welcome to AskUbuntu and thanks for your contribution. Note that the ordering of the answers can change - so would you rather that refer to 'answer #2` use ' the answer of @answerer'. – chesedo Jun 18 '16 at 19:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.