25

In order for me to boot into 12.04, I have to add the parameter acpi=off in grub. Any other options as specified here do not allow me to boot into Ubuntu.

My question is simple, what does setting the parameter acpi=off actually do?

And more importantly does repeatedly booting with acpi=off damage or harm the computer in anyway?

13

Using acpi = off disables your Advanced Configuration and Power Interface off temporarily while booting Ubuntu. If you have to add the acpi = off to let ubuntu boot successfully, it means that the ACPI on your computer isn't compatible with this version of ubuntu.

I don't think using acpi = off repeatedly wrecks your computer, because it only disables ACPI temporarily.

However, if you don't want to add the acpi = off parameters every time you boot, you can disable the new card (BIOS) or disable ACPI (also from the BIOS). Use the second option if you can't find the New Card Interface.

But, if you have Windows, disabling ACPI from the BIOS may wreck Windows and the computer will force you to reinstall it. So do that if you have a hidden windows recovery partition in your computer.

| improve this answer | |
  • How should disabling ACPI harm Windows? It disables ACPI-usage in the Linux kernel, but not modify the ACPI-table on the BIOS. Windows can't be affected. – user unknown May 19 '12 at 1:25
  • 1
    I actually disabled ACPI from the BIOS myself, and windows got an error of having "a serious problem" when I booted it. Fortunately, the computer had a hidden recovery partition (which I didn't know) and fixed the problem by itself. Then I searched online and found a bunch of people (no recovery partitions) that had to reinstall windows after disabling ACPI from the BIOS. But I'm also not so sure why. – Emerson Hsieh May 19 '12 at 1:31
  • 1
    Ah - you disable it in the BIOS, not in the GRUB boot-options? I thought you talked about the latter. – user unknown May 19 '12 at 1:42
  • Oh. I edited the question. Sorry for causing confusion. – Emerson Hsieh May 19 '12 at 2:03
12

I've recently purchased a HP Envy 17 j053ea machine to take advantage of the i7 and oodles of memory. Cutting to the chase I suffered from many issues with this install. The wireless didn't work, the screen "black screened" during installation and thereafter during booting. The get around for the black screen was the boot option acpi=off, but this of course meant that the laptop would not suspend when I closed the lid which is clearly suboptimal. After searching for the past two days I have found many good articles/explanations of acpi and a much better option:

For info on acpi see: http://www.tldp.org/HOWTO/html_single/ACPI-HOWTO/

For more info see: https://wiki.archlinux.org/index.php/ACPI_modules

Then I found: No ACPI support for my PC, what can I do? from irrational_john ... way to go .. acpi=ht didn't work but pci=noacpi has done the trick. For your hardware I'd recommend John's approach pf cycling through the options he provided:

nolapic
noapic
acpi_osi=“Linux”
acpi_osi=“Windows 2006”
acpi=ht
pci=noacpi
acpi=noirq
pnpacpi=off

With this in hand abd to address “wub's” .. on point answer above, once you find the one that works:

bash# cd /etc/default
bash# sudo vi grub
# Use the vi editor to add the boot options to the line  

GRUB_CMDLINE_LINUX_DEFAULT=

and make it (in my case):

GRUB_CMDLINE_LINUX_DEFAULT=“quiet splash pci=noacpi”

finish with:

bash# sudo update-grub
bash# sudo reboot
| improve this answer | |
  • I found that the options in GRUB_CMDLINE_LINUX_DEFAULT show for the default linux option but are missing in the recovery menu option. How do you add apci=off to the recovery menu option? – Sukima Mar 9 '14 at 1:58
  • @Sukima Add the options to ‘GRUB_CMDLINE_LINUX’ instead for them to be added to both entries – João Bravo Dec 9 '19 at 18:59
2

I had the same problem.

This is the fix:

Edit /etc/default/grub.

In the grub file, change GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" to be GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=Linux acpi_backlight=vendor".

Then do sudo update-grub and reboot! Courtesy of wub.

| improve this answer | |
  • 2
    This answer seems unrelated. It does not address this question. – Mahesh Sep 24 '12 at 18:19
0

Windows simply does not start without ACPI. I got a Sony laptop 'defect', because there is no way to change ACPI in BIOS, so Sony wanted to replace the motherboard for a huge amount of money. Btw. Windows will not be broken or harmed in any way with no ACPI, it simply does not start. Linux Ubuntu 20.04 works fine with that Sony - except - acpi=off disables also the Touch Pad. Tried nolapic and noapic plus acpi=off in all variations. Touch Pad did work but sometimes the Sony hangs in boot, error is non-deterministic. Only sole acpi=off without Touch Pad is stable.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.