I have been using Ubuntu 11.10 on my Macbook Air 4,2 for a time now and wanted to upgrade to 12.04. The upgrade process worked flawlessly until the reboot. After rebooting, my boot partition didn't work anymore and now I have to fix that by booting into a live usb stick.

The problem is: No matter what I do, I always end up with a black screen showing

Boot error

and a blinking cursor beneath.

This screen appears after I select the live usb in refit and press return (or the ubuntu boot partition, or the live usb-copied-to-harddisk-partition). I also get this black boot error screen when I don't use refit but the normal OSX boot manager (by keeping ALT pressed during boot).

Note that I do not get to see any other output; not grub, not the linux loader, not the ubuntu splash screen - nothing except this message.

I tried unetbootin with the normal desktop amd64 iso and the desktop+mac iso, also tried both converted to .dmg with hdiutil, and both with the script that the ubuntu installation instructions suggest.

All of them give me the black boot error screen.

What can I do to get past this error? What could be the reason for this error?

1 Answer 1


Seems my memory is bad: Using unetbootin with a msdos partition table + mac iso + dd'ing to harddrive partition actually made it boot.

  • 1
    Yes. After booting the live usb, I could chroot to my old installation and grub-install --force /dev/sda4 - that made it work.
    – cweiske
    May 19, 2012 at 10:45
  • What does grub-install --force /dev/sda4 do? Oct 3, 2013 at 11:56
  • install the boot loader on /dev/sda4 (the linux boot partition). see cweiske.de/tagebuch/ubuntu-on-macbook-air.htm#installer for the partition layout.
    – cweiske
    Oct 3, 2013 at 12:07

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .