-1

I have a samba share on a Windows machine that I want to mount to my Kubuntu 21.10 machine.

Here is the line i put in my fstab :

//XX.XX.XX.XX/Folder /mnt/VM-Folder/ cifs credentials=/home/username/.smbcredentials,uid=1000,gid=1000,forceuid,forcegid,users,noauto,rw,file_mode=0777,dir_mode=0777,noperm,iocharset=utf8 0 0

I have tried several versions of this line and this is the best I got.

The issue that I have here is that when I open one of the file (for example a ppt file with Libreoffice, I get the following error message :

Document file 'Doc.ppt' is locked for editing by:

Unknown User

Open document read-only or open a copy of the document for editing. Select Notify to open read-only and get notified when the document becomes editable.

When I look at the file, I see 777 permission and I am effectively the owner of the file and the group is correct.

I get the same sort of messages with other files (.txt).

Any idea what is happening ?

1 Answer 1

0

Does adding the nobrl option to your cifs declaration fix this issue?

//XX.XX.XX.XX/Folder /mnt/VM-Folder/ cifs credentials=/home/username/.smbcredentials,uid=1000,gid=1000,forceuid,forcegid,users,noauto,rw,file_mode=0777,dir_mode=0777,noperm,iocharset=utf8,nobrl 0 0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.