1

I've just installed Ubuntu studio 21.10 on a new Asus laptop. Its now dual Boot with W10. Wifi works as expected in W10 but not in ubuntu. Adapter is a Realtek RTL8821CE. Is shows up when I do sudo lspci but beyond that I'm lost in Terminal. Any help to get the correct drivers installed would be greatly appreciated

benm@Bens-asus:~$ lspci -nnk | grep 0280 -A3
03:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8821CE 802.11ac PCIe Wireless Network Adapter [10ec:c821]
        DeviceName: WLAN
        Subsystem: AzureWave RTL8821CE 802.11ac PCIe Wireless Network Adapter [1a3b:3040]
        Kernel modules: rtw88_8821ce
benm@Bens-asus:~$ sudo dmesg | grep 8821
[sudo] password for benm: 
[    3.899773] rtw_8821ce 0000:03:00.0: enabling device (0000 -> 0003)
[    3.901991] rtw_8821ce 0000:03:00.0: Firmware version 24.8.0, H2C version 12
[    3.924396] rtw_8821ce 0000:03:00.0: rfe 4 isn't supported
[    3.924819] rtw_8821ce 0000:03:00.0: failed to setup chip efuse info
[    3.924824] rtw_8821ce 0000:03:00.0: failed to setup chip information
20
  • 1
    Please edit your question to show the result of the terminal commands: lspci -nnk | grep 0280 -A3 and also: sudo dmesg | grep 8821
    – chili555
    Jan 30 at 14:31
  • I've pasted it in but it has changed the layout a bit
    – Rollem Neb
    Jan 30 at 14:42
  • Kernel 5.14 and above seem to address this issue/bug.
    – Someone
    Jan 30 at 14:57
  • Please try: sudo modprobe -r rtw88_8821ce and: sudo modprobe rtw88_pci disable_aspm=1 and then: sudo modprobe rtw88_8821ce Is there any improvement? Reference: bugzilla.kernel.org/show_bug.cgi?id=210779
    – chili555
    Jan 30 at 14:58
  • I have entered the code but it seemed to have no effect
    – Rollem Neb
    Jan 30 at 15:13

2 Answers 2

1

Please note the well-known bug report: https://bugzilla.kernel.org/show_bug.cgi?id=210779

rtw88_8821ce doesn't work [1] can't connect [2]

Let’s blacklist the native driver:

sudo -i
echo “blacklist rtw88_8821ce”  >>  /etc/modprobe.d/blacklist.conf
exit

Next, with a working internet connection by ethernet, tethering or whatever means possible, do:

sudo apt update
sudo apt install git dkms build-essential bc linux-headers-generic
git clone https://github.com/tomaspinho/rtl8821ce.git
cd rtl8821ce
sudo ./dkms-install.sh

Reboot, disable Secure Boot and your wireless should be working.

0

This guide should work:

Secure boot must be deactivated.

sudo apt-get install --reinstall git dkms build-essential linux-headers-$(uname -r)

git clone https://github.com/tomaspinho/rtl8821ce

cd rtl8821ce

chmod +x dkms-install.sh

chmod +x dkms-remove.sh

sudo ./dkms-install.sh

For deinstallation:

sudo ./dkms-remove.sh

Or you can try this:

sudo apt-get install --reinstall dkms build-essential linux-headers-$(uname -r)

wget https://launchpad.net/~canonical-hwe-team/+archive/ubuntu/rtl8821ce/+files/rtl8821ce-dkms_5.2.5.2.1.30816.20190425-0ubuntu1_all.deb

sudo dpkg -i *.deb

For further instructions look here:

https://forum.ubuntuusers.de/topic/wlan-modul-nicht-aktieviert-unter-ubuntu-18-04/#post-8985121

1
  • You probably also need to blacklist the native driver.
    – chili555
    Jan 30 at 18:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.