2

Preface : I had "No wifi adapter found" issue on my pc. I asked No wifi adapter found on Ubuntu 20.04.3 LTS, & the answer chili555 given was working fine.

Today after a restart, I am encountering a new issue. Now, wifi is enabled but it can't find any wifi networks. (though USB-Tethering works). The kernel version is 5.13.0-27-generic

  1. Output of iwconfig :
lo        no wireless extensions.
usb0      no wireless extensions.
wlp1s0    IEEE 802.11  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=3 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:on
docker0   no wireless extensions.
  1. sudo lshw -C network :
  *-network                 
       description: Wireless interface
       product: MEDIATEK Corp.
       vendor: MEDIATEK Corp.
       physical id: 0
       bus info: pci@0000:01:00.0
       logical name: wlp1s0
       version: 00
       serial: c8:94:02:c1:7a:7b
       width: 64 bits
       clock: 33MHz
       capabilities: pciexpress msi pm bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=mt7921e driverversion=5.13.0-27-generic firmware=____010000-20211014150922 latency=0 link=no multicast=yes wireless=IEEE 802.11
       resources: irq:88 memory:e0300000-e03fffff memory:e0400000-e0403fff memory:e0404000-e0404fff
  *-network
       description: Ethernet interface
       physical id: 1
       bus info: usb@1:2
       logical name: usb0
       serial: 82:75:76:11:9e:70
       capabilities: ethernet physical
       configuration: autonegotiation=off broadcast=yes driver=rndis_host driverversion=5.13.0-27-generic duplex=half firmware=RNDIS device ip=192.168.42.130 link=yes multicast=yes port=twisted pair

  1. rfkill list all :
0: hci0: Bluetooth
    Soft blocked: yes
    Hard blocked: no
1: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no

  1. sudo iwlist scan:
lo        Interface doesn't support scanning.
usb0      Interface doesn't support scanning.
wlp1s0    No scan results
docker0   Interface doesn't support scanning.

  1. lspci -nnk | grep 0280 -A3:
01:00.0 Network controller [0280]: MEDIATEK Corp. Device [14c3:0608]
    Subsystem: MEDIATEK Corp. Device [14c3:0608]
    Kernel driver in use: mt7921e
    Kernel modules: mt7921e

  1. sudo dmesg | grep mt7:
[    3.629484] mt7921e 0000:01:00.0: enabling device (0000 -> 0002)
[    3.629700] mt7921e 0000:01:00.0: disabling ASPM  L1
[    3.629746] mt7921e 0000:01:00.0: ASIC revision: 79610010
[    3.712374] mt7921e 0000:01:00.0: HW/SW Version: 0x8a108a10, Build Time: 20211014150838a
[    3.724385] mt7921e 0000:01:00.0: WM Firmware Version: ____010000, Build Time: 20211014150922
[    3.754924] mt7921e 0000:01:00.0: Firmware init done
[    5.326846] mt7921e 0000:01:00.0 wlp1s0: renamed from wlan0

I have also tried sudo apt-get install --reinstall network-manager, sudo systemctl restart network-manager.service, sudo /etc/init.d/network-manager force-reload, Reboot mutiple times. But No luck !!

16
  • Please post the output of lspci -nnk | grep 0280 -A3 and uname -r. Welcome to Ask Ubuntu!
    – Error404
    Jan 30 at 11:39
  • Hi @Someone, I have added those output on my post.
    – Arnob Saha
    Jan 30 at 11:42
  • Hmmm, interesting. Seems like your device is new, is it? We've many questions regarding MediaTek 7000+ won't work on 20.04. So, I'd recommend upgrading to Ubuntu 21.10 with kernel 5.16. That's probably the best option there.
    – Error404
    Jan 30 at 11:51
  • Yes, my device is relatively new. Thanks for the recommendation. But, Isn't there any way to solve this issue for now ?
    – Arnob Saha
    Jan 30 at 11:55
  • 1
    Actually, the device only works on kernel 5.15 or above (disclaimer: I have the same card as you). But you won't be able to install 5.15 on 20.04.
    – Error404
    Jan 30 at 11:59

3 Answers 3

1

You are using a relatively new and modern Wi-Fi adapter. As far as I know, this adapter doesn't work with the kernel version lower than 5.14. However, kernel 5.15.7+ is not installable on Ubuntu 20.04 LTS. If we look at kernel 5.14, it's EOL. So unfortunately, you cant use your Wi-Fi adapter with 20.04! You've to perform a fresh install of 21.10 (or upgrade using sudo do-release-upgrade) and follow the steps in my this answer and install kernel 5.16.

I'm using the same Wi-Fi adapter as you.

3
  • What do you mean by "kernel 5.15.7+ is not installable on Ubuntu 20.04 LTS"?
    – Pilot6
    Jan 30 at 13:27
  • It's because of the libc6 dependency. @Pilot6 see the link mentioned in my answer
    – Error404
    Jan 30 at 13:28
  • Hello @Someone, I have tried the steps from your given link.. But my kernel version didn't upgrade. Output of the commands :: go.dev/play/p/uY_3XaucA-v . When restarting, It enforces me to choose a kernel version between i) 5.16 ii) 5.16 (recovery mode) iii) 5.13 iv) 5.13(recovery mode). Choosing first 2 option does nothing. So I had to choose 5.13 kernel version. Can you please help me in this issue ?
    – Arnob Saha
    Feb 8 at 16:46
1

In terminal do

sudo ifconfig wlp1s0 up
sudo iwconfig wlp1s0 power off
sudo iwconfig wlp1s0 txpower 18

That is what we did in chat to get it running, https://chat.stackexchange.com/rooms/133648/discussion-between-arnob-saha-and-jeremy31

-2

Run the module version sanity check, it will show whether the original module exists within the kernel.

sudo apt install --reinstall bcmwl-kernel-source

Ater checking for original module and if not found it will add the generic one.

2
  • 2
    This command is related only to Broadcom devices, it is not relevant.
    – Pilot6
    May 19 at 21:13
  • Thanks for the clarification. I didn't know that. May 19 at 21:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.