0

My Linux system (KUbuntu 20.04 KDE) is connected with Windows Active Directory.

I am able to ping the IP address of Linux box from the network PCs of the Domain. I can see the hostname of my Linux box as well using the ping -a command.

The problem is that, when I am pinging the hostname instead of IP address, then it's not getting a response from the Linux box.

2
  • Hello and Welcome to Ask Ubuntu. A heads-up that I've removed the windows-subsystem-for-linux (WSL) tag since you do not seem to be using that feature. WSL is a feature of Windows 10 and later that allows you to run a Linux distribution inside Windows. If you are using Kubuntu, it is almost certain that you are not using WSL. If I've removed the tag in error, please update your question to clarify your WSL installation. Thanks! Jan 28, 2022 at 13:17
  • when I am pinging the hostname instead of IP address, then it's not getting a response from the Linux box This doesn't depend on the Ubuntu client, it depends on the AD controller. Jan 28, 2022 at 14:49

1 Answer 1

0

Diagnosis:

  • Get full domain name (full-domain-name) of your Active Directory. Usually it is somedomain.local or somedomain.lan etc.
  • Get Linux box supposed FQDN, i.e fully qualified domain name linuxbox-name.full-domain-name. Example: mybox01.somedomain.lan
  • Check DNS records.

1. Check of DNS A-record:

On Windows machine use

nslookup linuxbox-name.full-domain-name

On Linux use

dig linuxbox-name.full-domain-name

Check answer/answer section. If no valid IP address is listed, it means no DNS record exists for such name in domain.

2. Check of DNS PTR-record:

On Windows machine use

nslookup linuxbox-IP-address

On Linux use

dig -x linuxbox-IP-address

In case you get valid FQDN device name in DNS server response, compare it with your supposed FQDN in first test above, correct the name and repeat the first DNS check.

In case both checks are negative, your linuxbox does not have DNS records and its name cannot be used for network communication.

Possible solutions: Ask domain administrator for setting to create DNS A-record automatically by DHCP server if device is connected to network. Or ask him for DHCP static reservation for your device (MAC address - IP address) and for related DNS record.

1
  • When i ran "nslookup linuxbox-name.full-domain-name" command from Windows Laptop, found replay --> "Request to full-doman-name timed-out". Moreover, when i ran "dig -x linuxbox-IP-address" command from Linux box, found reply ---> "connection timed out; no servers could be reached" So, what will be the possibilities of this issue? Any help is highly appreciated. Feb 3, 2022 at 9:45

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .