3

It seems the last version for ubuntu 18.04 is rsync 3.1.2 (with !apt-get --only-upgrade install rsync).

Is there a way I can update it to the latest? (preferably 3.2.1+) Thanks!

3
  • 2
    Does this answer your question? Why don't the Ubuntu repositories have the latest versions of software?. Why do you need a different version? What feature is missing from your current software? Are you experiencing any problems?
    – Nmath
    Jan 28, 2022 at 9:08
  • 3
    For close voters. OP does not ask "Why it is old?". OP asks "How to install newer version?".
    – N0rbert
    Jan 28, 2022 at 9:13
  • @Nmath The old version is very buggy. I even ended up reporting a solved issue to the devs, eventually finding out that the issue was already fixed on later versions. github.com/WayneD/rsync/issues/232 After that, I managed to update by some non-standard method, which is not working anymore, thus asking this question. Finally, N0rbert's solution is very easy and works like charm. I should've asked this question long ago. Jan 28, 2022 at 10:01

1 Answer 1

6

You can install newer rsync (3.2.3-8ubuntu1~18.04.sav0) from Rob Savoury's Utilities PPA by

sudo apt-add-repository ppa:savoury1/utilities
sudo apt-get update
sudo apt-get install rsync

Reverting to default version is possible by

sudo apt-get install ppa-purge
sudo ppa-purge ppa:savoury1/utilities
2
  • I had to run sudo ppa-purge ppa:savoury1/utilities twice for it to downgrade rsync back to the default version Feb 7, 2023 at 21:46
  • Works for 16.04 too. Thanks
    – EthraZa
    Oct 12, 2023 at 14:12

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .