0

I am having a problem with my email program, Thunderbird. Up until 2 days ago, this has been working flawlessly for years, until it suddenly stopped sending or receiving emails. My initial thought was that a setting had been corrupted somewhere, but I checked everything (IMAP, SMTP settings etc.). I contacted my ISP, and confirmed with them that my settings were correct, username and password (I can still log into my web mail just fine) etc. Everything is as it should be. I have tried uninstalling Thunderbird using apt remove, and opted to install the Snap version instead, but still, Thunderbird absolutely refuses to communicate in any way. I have noticed that even if I go into Thunderbird Help, and click on one of the links there, they are instantly blocked too!

As a sanity check, I also have another laptop running Linux Mint. I installed my profile on Thunderbird on that machine, and in a matter of minutes I had my email running (exact same user credentials, ISP, home network, email account). I am therefore thinking that this has got to be an OS problem on my desktop. This is no longer looking like a Thunderbird/Profile/ISP/Network issue.

How and why is Thunderbird (version 91.5.1 64bit) suddenly blocked from the Internet on my Ubuntu 20.04.3 LTS (x86-64) based desktop? Is there a firewall issue I am not aware of perhaps?

Thanks guys.

Update I just tried again, and this is still not working! See the screenshot, where I have attempted to use the auto-config option when setting up a new account in Thunderbird. The exact same process works without a problem on my laptop on the same network, and the laptop is running Linux Mint...

Thunderbird email fails to connect to server under Ubuntu Thunderbird email fails to connect to server under Ubuntu

Thunderbird correctly detects settings from mail server under Linux Mint enter image description here

7
  • is the authentication method changed from normal password to Oauth2?
    – s3idani
    Jan 27 at 19:42
  • Is TB in offline mode? Check the icon in the lower-left corner of the TB window.
    – heynnema
    Jan 27 at 19:49
  • In answer to Oauth2, no this is a paid web service. I'm not using spyware like Google. IE no Oauth2 ever required :)
    – witenitenz
    Jan 28 at 4:00
  • No, TB is not running in offline mode, but good point though. I just double checked.
    – witenitenz
    Jan 28 at 4:15
  • Good to hear it's resolved at least! It's fair to close this as "Can no longer be reproduced", at least, right? In other words, no one's going to come up with a different solution that will help you resolve this, so there's never going to be an "accepted answer" that will help others with the same issue, right? Jan 31 at 21:40

3 Answers 3

0

Switch from Start-TLS to TLS worked for me...

1
  • Sorry, nope. I tried all options here, and just tried again (now) to run the automatic configuration when setting up a new account. the exact same process works just fine on my laptop with the same version of TB installed, on the same network. Only difference is the laptop is running Linux Mint, while my desktop is running Ubuntu 20.04
    – witenitenz
    Jan 31 at 3:20
0

Well, I thought I had fixed this, but no. What I did was uninstall Thunderbird (apt-get remove) and then install it using the SNAP version. After this I discovered that my VPN was getting in the way, and with it disabled I had working email again. Thought I had solved my problem, except now that bloody Thunderbird has no credible means of restoring an old profile, all my emails were "lost". Today I attempted to restore my original version (apt-get install thunderbird) and voila, my emails and profile are all back, but I am back to square one again, being unable to send or receive new emails!

Basically, (today) when I attempt to setup a new account (although my old profile account should work jut fine, as nothing has changed) I get this:

enter image description here

Regardless of whether I try to get the certificate or "confirm Security Exception" I end up with this:

enter image description here

The Snap install at least proved one thing. There is nothing wrong with my installation of Thunderbird/credentials/network etc. etc. as this was working (I could download and send emails no problem via Snap version of Thunderbird) but as soon as I go back to the original method of install (but exactly the same version of Thunderbird) that has worked for years (even with a complete reinstall) Ubuntu is simply blocking it from working! This is truly frustrating and been going on for weeks now!

0

What if your initial suspicion was correct? Sudo apt remove would remove the binary, but leave the config files. Since it worked fine on another device, one might reasonably assume a corrupted config file, as those were not recreated, but re-used.

Sudo apt purge will do everything "remove" does, but also irrecoverably remove all config files.

4
  • I did consider this, which is why I tried to setup a brand new account in Thunderbird. Those are the results you see in my most recent post. I wouldn't think that a corrupted profile would "spread" to a brand new account in the same instance of Thunderbird. Not 100% sure of that though. Thunderbird doesn't appear to offer any means for repair (along with backup/restore of profile/emails) so no easy way to do a repair if this is indeed the case, that the configuration is globally broken. I wonder if I can backup the .thunderbird email/profile folder, purge and then re-instate it.
    – witenitenz
    Feb 8 at 0:31
  • Nope, just tried it. 1. backup .thunderbird email/profile 2. apt purge thunderbird 3. Confirm it has been deleted 4. apt install thunderbird 5. Restart Thunderbird (I noticed my .thunderbird folder was not removed throughout this process). Same faulty result
    – witenitenz
    Feb 8 at 0:39
  • OK, tried something a bit different. I deleted the .thunderbird directory and restarted Thunderbird. As expected, it failed to find or startup with my usual profile. I then went in and created a new one. It twirled around for some time while communicating with the server (I think it was probably synchronizing emails) and then started up just fine! So this is definitely something broken in that .thunderbird profile setup! And it doesn't get removed, even if you run the full blown purge (which I suppose makes sense.
    – witenitenz
    Feb 8 at 0:48
  • Thanks! At least I've made some genuine progress thanks to your purge suggestion. This takes the heat off my Ubuntu suspicions. Thanks a lot!
    – witenitenz
    Feb 8 at 0:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.