I am following this tutorial: https://tensorflow-object-detection-api-tutorial.readthedocs.io/en/latest/install.html#tf-models-install and more specifically: Install the Object Detection API

When I run this command:

python -m pip install --use-feature=2020-resolver .

I get:

/usr/bin/python: No module named pip

I tried the following combinations:

UbuntuUser@ubuntu:~/Desktop/TensorFlow/models/research$ sudo python -m pip install --use-feature=2020-resolver .
/usr/bin/python: No module named pip
UbuntuUser@ubuntu:~/Desktop/TensorFlow/models/research$ sudo python3 -m pip install --use-feature=2020-resolver .

  /usr/bin/python3 -m pip install [options] <requirement specifier> [package-index-options] ...
  /usr/bin/python3 -m pip install [options] -r <requirements file> [package-index-options] ...
  /usr/bin/python3 -m pip install [options] [-e] <vcs project url> ...
  /usr/bin/python3 -m pip install [options] [-e] <local project path> ...
  /usr/bin/python3 -m pip install [options] <archive url/path> ...

no such option: --use-feature
UbuntuUser@ubuntu:~/Desktop/TensorFlow/models/research$ sudo python3 -m pip3 install --use-feature=2020-resolver .
/usr/bin/python3: No module named pip3
UbuntuUser@ubuntu:~/Desktop/TensorFlow/models/research$ sudo python -m pip3 install --use-feature=2020-resolver .
/usr/bin/python: No module named pip3

Both pip and pip3 are install in Ubuntu Mate:

What is wrong?? I tried on google: /usr/bin/python: No module named pip , after installing pip it didn't help...

  • 4
    Run sudo apt-get install python3-pip and retry.
    – N0rbert
    Jan 27, 2022 at 18:39
  • 2
    You can see pip does work for python3 -m pip, you might have to update it. What does it print out when you do python3 -m pip -V? It's saying the --use-feature option doesn't exist, you might have to update it
    – GammaGames
    Jan 27, 2022 at 18:42
  • 1
    @just_learning That option was added in 20.0.3, the pyhon3 -m pip install --upgrade pip should have worked. What if you leave off the option?
    – GammaGames
    Jan 27, 2022 at 20:44
  • 1
    @just_learning I mean to only run python -m pip install . and see what happens. The --use-feature=2020-resolver is a feature added to allow users to use a newer dependency resolver.
    – GammaGames
    Jan 27, 2022 at 23:31
  • 1
    @just_learning I'm not sure, but that would be a problem for another question. I'm not familiar enough with tensorflow to know what the issue is
    – GammaGames
    Jan 28, 2022 at 15:45

1 Answer 1


As you can see, pip does work when invoked with python3 -m pip. From the comments we've discovered that you are running v20.0.2. The --use-feature option was not added until 20.2 and, since the usual command to upgrade pip was not working, we omitted the option and it ran successfully.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .