54

How to disable blank screensaver on Ubuntu Server?

There's no desktop or X, only console (command-line interface).

52

The easiest way is to add the parameter consoleblank=0 to your kernel command-line at boot-time.

  • Open /etc/default/grub in your favorite editor; you will need to use sudo (for vi, nano, etc.) or gksudo (for gedit, etc.).

  • Then add consoleblank=0 to the GRUB_CMDLINE_LINUX_DEFAULT=, parameter.

  • e.g. yours may say:

    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash consoleblank=0"

Then run sudo update-grub, and reboot.

  • Is there a way to do that from Virtualbox? As in passing an option to the kernel command line? – CMCDragonkai Jun 5 '14 at 4:56
  • @CMCDragonkai This answer works for virtualized Ubuntu as well since it boots using grub by default too. – Melebius Jan 21 '15 at 9:42
  • As in, is there a way to pass it externally from Virtual Box, not from within Ubuntu? – CMCDragonkai Jan 22 '15 at 0:28
  • @CMCDragonkai No, there is no Virtual Box option that will pass on this setting. You have to edit the file as specified above. – Rick Chatham Feb 11 '15 at 22:09
  • 1
    Look: I don't want to update the grub files, just to disable the (Blank) ScreenSaver. I'm resorting, to setterm -blank 0, maybe in a file ~/.bashrc. (See also on superuser.com an answer to Change Linux console screen blanking behavior) – metadings Sep 26 '16 at 13:21
20

Type setterm -blank 0 on any shell to disable blanking out of tty consoles.

0 disables blanking, any value greater than 0 is the time in minutes. Default is 10.

To permanently enable this you can add this line to your ~/.bashrc config.

A more detailled explaination can be found in this answer at superuser.

  • This only worked after I ran TERM=linux (since I override it in my .bashrc). – Wesley Baugh Jun 14 '16 at 4:46
  • Does not unblank the master terminal. – mckenzm Apr 22 '17 at 5:51
1

This will "overwrite" whatever is in your current config for "GRUB_CMDLINE_LINUX_DEFAULT=", mine was default, so I just use the following One Liner.

sudo sed -i 's/\(^GRUB_CMDLINE_LINUX_DEFAULT=\).*/\GRUB_CMDLINE_LINUX_DEFAULT="consoleblank=0"/' /etc/default/grub && sudo update-grub2
  • I had to escape the '"' character: sed --in-place 's/(^GRUB_CMDLINE_LINUX_DEFAULT=).*/\GRUB_CMDLINE_LINUX_DEFAULT=\"quiet consoleblank=0\"/' /etc/default/grub – W1M0R Dec 13 '17 at 7:20
1

Same situation, the other suggestions seemed a roundabout solution. Came across the GNU tool setvesablank on/off using apropos. It seems the best fit, trying it out to see if it fits the need.

  • In Gnome Terminal on the console it said Couldn't find a file descriptor referring to the console - echo $TERM returned `xterm-256color - But in "Brightness and Lock" I found a setting for when it blanks the screen and set it to "Never" - but this isn't really on point with the OP since I am in the GUI. – SDsolar Jan 10 '18 at 19:41
0

If none of the above answers work for you, this may be indicative of GPU auto shutoff due to overheating ( I couldn't believe it myself, readon ).

This auto shutoff mechanism is valid in at least Ubuntu 18.04 and Debian Buster. How did I discover this? I have two gpus, a basic video outputer and a gaming gpu; not in sli nor in crossfire. The former I had to remove the heatsink to fit in the case. When I kept my Ubuntu installation and used my gaming gpu instead, the screen would not turn off after 10 min, after logging in with the above patches (answers on this page applied). At first, I thought it was due to crappy generic drivers, so I did the following whilst my gaming gpu was being utilized.

apt search nvidia-driver

sudo apt install nvidia-driver-430

sudo reboot

sudo nvidia-smi (after login)

Video GPU 73 degrees celcius, gaming gpu 34 degrees celcius...autoshutoff mechanism proven as far as I am concerned.

Current active nvidia processes 0 (still using the piece of shit generic driver for console, but 73 degrees celcius and anecdotal evidence points to autoshutoff mechanism being triggered.

What is frustrating is the Windows 10 installed and ran without flaw without the heatsink so this was very unexpected...I must have misread GPU-Z because I saw 34 degrees being reported unless there's a bug in GPU-Z where it just basically takes one temperature reading and displays it for both gpus. Nvidia-smi is much more reliable than GPU-Z. Don't trust GPU-Z if it reports the same temps for two different gpus.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.