2

I have a dual boot Lubuntu 21.10 / Windows laptop. Recently it won't suspend (sleep). No matter I do it from start menu or use command line pm-suspend or systemctl suspend . After trying to suspend, laptop's fan turns on with high speed, maybe trying to cool the CPU. Anyway, latop won't enter suspend even after 15 minutes. Neither, power led goes blinking or fan stops.

Saw logs by command sudo journalctl -b -1 -e but nothing special I found.

I checked many other question like this but no success.

Also I added GRUB_CMDLINE_LINUX_DEFAULT="acpi=force" to /etc/default/grub but the only difference was that fan speed did not go high speed.

Consider that Windows suspend correctly. Even the Lubuntu was sleeping correctly few months ago.

I am trying a couple of work-arounds to resolve this issue:

  1. I upgraded to version 21.10 but nothing changed.. It was 21.04 when I started to see this issue. When I try to suspend my laptop manually or by the command systemctl suspend, just the screen turns off. Fan and power LED are still turned on even after 5 minutes. Also laptop won't turn on by pressing keys or touching mouse, only a forced shutdown by pressing the power button for some seconds forces a shutdown.

  2. Tried Windows to make sure. It suspends correctly: fan is turned off and power LED goes blinking. Also tried both Windows shutdown and restart. Same problem exists.

  3. Was suspect about network card, so turned it off by nmcli radio wifi off, fail again.

  4. Checked suspend logs with command journalctl | grep systemd-sleep and found "BIOS may not properly restore RDRAND after suspend". My Laptop is on AMD CPU. Then searched and found a solution and applied it as:

    sudo featherpad /etc/default/grub
    GRUB_CMDLINE_LINUX_DEFAULT="rdrand=force"
    sudo update-grub
    

but stil failing.

Update: I can see that the shutdown does not work as well. When I shut down, laptop fan goes high speed, screen is black and power led still is on.

Update 7 Feb. 2022

Shutdown and suspend returned to my laptop automatically. From my last activity on this issue I just did 1 or 2 regular updates of the OS and nothing else. And the problem is solved now. I do not know why.

2
  • @guiverc I upgraded to 21.10 which is not in end-of-life period for now. So this should not be unsupported now.
    – Afshar
    Jan 26, 2022 at 20:18
  • update/upgrade to 5.13.0-27-generic gave me suspend, still resume to blank screen and ctrl-leftclick mouse to resume, plus need to replug the usb. after 3 years of waiting, this is an improvement.
    – pierrely
    Jan 29, 2022 at 4:07

0

This site is temporarily in read-only mode and not accepting new answers.

Browse other questions tagged .