How can I make a bash script executable by double clicking just like .exe files in Windows? I tried creating a launcher and assigning the script to it, but there are two consequences:

  1. the terminal twinkles, disappears, and nothing is done.
  2. you must specify to run in terminal in order to work.

I have a script that installs tomcat on an offline PC, including all dependencies of tomcat in the script. I need to make the script work on double clicking like windows since most who use the script will not be familiar with Ubuntu.

Forget the above explanation. I want to make a script that can be run by double-clicking on it, without using the terminal. Anybody knows how?

  • I think you may just be writing your desktop file poorly. Can you post (verbatim) the .desktop launcher that you wrote? – Jjed May 18 '12 at 15:25
  • Also, have you seen this? askubuntu.com/q/34597/24694 – Jjed May 18 '12 at 15:27
  • Its just a launcher where you assign name and command to do its not that big idea – user61928 May 19 '12 at 6:38
  • Also note, that scripts in linux are not called bash but shell afaik. – cauon Oct 5 '12 at 8:58
  • 3
    muru tipped me off to this, worked for me: askubuntu.com/questions/286621/… – draoi Nov 16 '15 at 23:56

I tested this and it worked fine. Ensure your script begins with the correct hash-bang, e.g. #!/bin/bash

Then follow these steps:

Hit Alt+F2, type dconf-editor and hit Enter.

In dconfg-editor goto: org ➤ gnome ➤ nautilus ➤ preferences

Click on executable-text-activation and from drop down menu select:

launch: to launch scripts as programs.

OR

ask: to ask what to do via a dialog.

Close dconf-editor. Thats it!

Source: How do I run executable scripts in Nautilus? Answer courtesy of Basharat Sial.

  • This worked great. Just a note, the "drop down menu" is reached by clicking on the value listed to the right of executable-text-activation (default value is display). – ryanjdillon Aug 14 '13 at 10:50
  • 2
    for those who cannot call the app, you need to install it first with sudo apt-get install dconf-editor – whale_steward Mar 14 '15 at 6:35
  • 1
    This works everywhere except on the Desktop. How can I make it work on the Desktop as well? I'm using Xubuntu 14.10. – shrx Mar 28 '15 at 17:17
  • Is there a way to do this in LXDE (for Lubuntu)? – childofsoong May 2 '15 at 20:05
  • This works great under slax unix to -- see slax.org for the really great Unix system you can boot off of a thumb drive. – raddevus Dec 5 '15 at 22:42

On the newer versions, on nautilus (files), go to Edit > preferences > Behaviour tab > and change the settings for executable text file.

  • 3
    Now 'Files -> Preferences'. (17.04) – niry Sep 27 '17 at 20:23
  • Sweet! The way to go imho. – codepleb Oct 12 '17 at 6:11
  • How to see output ? – Amr Lotfy Aug 29 at 1:00

In Ubuntu and all Unix based OSes, afaik, nothing is set as executable by default. There are two ways of doing this.

  1. Right click on the script or file you want to execute. Go to Properties then to the Permissions Tab. Click the check box that says Execute.

  2. Open a Terminal cd into the directory where the file is found. Type chmod ugo+x filename. This will set the file to execute.

Now your users can double click to their hearts content.

  • 2
    It still will ask you what to do with run in terminal or display or run ... So its not what i need – user61928 May 19 '12 at 6:34
  • Only this answer worked on Gnome Ubuntu 17.04 for making desktop file executeable – Kunok Apr 14 '17 at 21:06

I think creating a *.desktop file is missing here:

$ cat shortcut-for-my-script.desktop
[Desktop Entry]
Type=Application
Terminal=true
Name=Click-Script
Icon=utilities-terminal
Exec=gnome-terminal -e "bash -c './script.sh;$SHELL'"
Categories=Application;

If you create more than one *.desktop file for one script you are able to create multiple configurations by passing different parameters, which is a very comfortable and user-friendly way.

If you're using XFce then you can make script executed in Thunar by executing this command:

xfconf-query --channel thunar --property /misc-exec-shell-scripts-by-default \
             --create --type bool --set true

or by using gui xfce4-settings-editor and creating the same property

You have to check 3 points :

When you create a launch in Desktop to a SHEL script or Whatever, in command line, don't forget to signal the script, to be executed in background.

The script will die when he finished is job.

  • 1
    i did that but what prob is the terminal just twinkles and nothing happens – user61928 May 19 '12 at 6:36

Based on umask defualt value, you haven't execute permissions for files by default and must change mod to gain execute permissions, something like this:

chmod u+x filename
  • 1
    Broth Ali sure i did it its obvious to do that – user61928 May 19 '12 at 6:35

Specially for Android Studio You can follow my original answer here:

To Create Desktop Launcher:

  • Click on Create Desktop Entry.. from Tools menu.

enter image description here

  • It will be prompt for password, enter password of your current login.

  • Finally it will be display notification in Android Studio screen like:

enter image description here

  • You can see in Applications => Programming => Android Studio, and you may see on desktop also after restarting system.

Thank you. :)

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.