I need to install a newer license server on my Ubuntu 20.04.3 LTS server. The license server need the lsb package, which cannot be installed showing the error: (I use apt install lsb...)

lsb: Depends: lsb-core [...] lsb-printing ... but it is not going to be installed.
When I follow the shown packages (lsb-core and lsb-printing are the first of a longer list) I come to that point:
libc6-dev: Depends: libc6 (= 2.31-0ubuntu9.2) but 2.310ubuntu9.3 is to be installed

There I got stuck since 6 weeks now. For me it looks like a wrong dependency inside that libc6-dev package and I don't know how to solve that. I've even tried to download the needed packages and try dpkg -i ... but same error appears. Anything I can do now? Thanks in advance!


  • 1
    Please edit your question and show us apt-cache policy libc6
    – nobody
    Jan 24, 2022 at 12:35
  • libc6: Installed: 2.31-0ubuntu9.3 Candidate: 2.31-0ubuntu9.3 Version table: *** 2.31-0ubuntu9.3 100 100 /var/lib/dpkg/status 2.31-0ubuntu9.2 500 500 de.archive.ubuntu.com/ubuntu focal-updates/main amd64 Packages 2.31-0ubuntu9 500 500 de.archive.ubuntu.com/ubuntu focal/main amd64 Packages
    – JPS
    Jan 24, 2022 at 12:50
  • 1
    sudo apt install --reinstall libc6=2.31-0ubuntu9.2
    – nobody
    Jan 24, 2022 at 12:56
  • Perfect, problem solved. Many thanks!!!
    – JPS
    Jan 24, 2022 at 14:37

1 Answer 1


From the comments...

As suggested by nobody, OP ran:

sudo apt install --reinstall libc6=2.31-0ubuntu9.2

To install the correct version of the libc6 package.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .