4

I have been away for 4 months and when I started Ubuntu again there were 0 updates available. That seems very odd to me. I tried several times and always got that the same result: packages are all up to date. How can that be? Any suggestions?

Ubuntu 20.04.3 LTS - 64-bit - Gnome Version 3.36.8

$ sudo apt update
OK:1 http://archive.ubuntu.com/ubuntu focal InRelease
OK:2 http://archive.canonical.com/ubuntu focal InRelease               
OK:3 https://deb.opera.com/opera-stable stable InRelease               
Paketlisten werden gelesen... Fertig           
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Alle Pakete sind aktuell.
7
  • 22.04 is around the corner, 4 months with no update is definitely possible. Especially when you seem to have only very few repos enabled. I have security, updates, backports, main, universe in addition to what you have enabled.
    – emk2203
    Jan 23 at 10:46
  • 2
    Restore default repository, I kinda miss focal-updates and focal-security. gist.github.com/ishad0w/788555191c7037e249a439542c53e170
    – nobody
    Jan 23 at 13:56
  • 5
    Does this answer your question? How do I restore the default repositories?
    – Someone
    Jan 23 at 13:57
  • 2
    Your Ubuntu system did not delete the focal-updates and focal-security sources itself. Whatever reason you had for disabling/deleting those sources, it was unwise. Restore them, and don't do that again.
    – user535733
    Jan 23 at 15:38
  • 1
    Thanks emk2203, Mark, nobody, user535733 and specially Someone for the copy-past command line. The update works now and the sources are complete. I don't know how the sources got deleted or disabled, make me worried about the safety of my computer. How can I check if my system got compromised?
    – Patrick
    Jan 25 at 10:08

1 Answer 1

11

Seems like an issue with the repositories. Check if your mirror is up to date. Then follow these steps:

  1. Open Software and Updates app.

    sudo software-properties-gtk
    
  2. As you want ALL the upgrades, I recommend enabling ALL the repositories:

    Enable all repositories.

  3. Then change the mirror to "Main Server".

  4. Update:

    sudo apt update 
    
  5. Then upgrade:

    sudo apt upgrade
    

Here is a one line copy-paste friendly command for the above steps:

sudo mkdir ~/answer && cd ~/answer/ && sudo wget https://gist.githubusercontent.com/ishad0w/788555191c7037e249a439542c53e170/raw/3822ba49241e6fd851ca1c1cbcc4d7e87382f484/sources.list && sudo sed -i "s/focal/$(lsb_release -c -s)/" ~/answer/sources.list && sudo mv ~/answer/sources.list /etc/apt/ && sudo apt update && sudo apt upgrade  && sudo rm -rf ~/answer
1
  • It indeed may well be that all repositories were turned off for one or another reason.
    – vanadium
    Jan 23 at 12:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.