19

I recently got a backlit keyboard, and I LOVE to write late at night.

But I cannot for the life of me figure out how to light it up...It lights up when first plugged in, but nothing happens after that....

It is an 'XtremeIT' keyboard. There is a video of someone on Ubuntu who managed to activate it...

5
  • 1
    We need to know what kind of backlit keyboard it is, is it usb, built into a laptop etc. – Martin Owens -doctormo- Nov 18 '10 at 18:37
  • What model is the keyboard? I have the old G15 and mine lights up fine. Usually the keyboard itself has a button to enable/dim/brighten the light. – James Denham Nov 18 '10 at 18:48
  • XtremeIT keyboard :) Sorry, should of mentioned that sooner! – Dante Ashton Nov 23 '10 at 13:18
  • Does the keyboard have problem only with Ubuntu machine and works fine with other platform? Sorry if am sounding foolish. – user11230 Feb 21 '11 at 21:23
  • Can i do this on my mac ?? can some one explain me how ? – user311086 Jul 31 '14 at 20:12

11 Answers 11

19

Did you try the script the YouTube poster suggested in his own comments?

Basically use xset to toggle the state of the led backlight.

#!/bin/bash
if [ -f /tmp/keyboard_light ]; then
  xset -led 3 && rm /tmp/keyboard_light
else
  xset led 3 && touch /tmp/keyboard_light
fi
2
  • It does work! but it turns on the mouse keys, anyway to enable it without losing the numberpad function and having to manually disable it everytime? – Muaad ElSharif Dec 24 '18 at 16:57
  • My makeshift fix is this command: gsettings set org.gnome.desktop.a11y.keyboard mousekeys-enable true – Muaad ElSharif Dec 24 '18 at 17:08
9

open terminal then type:

xset led on 

to turn on backlight, and type:

xset led off

to turn it off.

3
  • I get "unable to open display". I'm using ubuntu server – RollRoll Nov 18 '17 at 0:23
  • uhm.. maybe you have to try it: xset led 3 – arif ardiansyah Nov 18 '17 at 9:17
  • this one allowed me to turn the leds on/off but I lost the numpad with the leds on. – Jorge Alberto Díaz Orozco Jun 20 '20 at 19:19
4

for those who land here because they also want the keyboard to light up BEFORE the login screen:

Finally Found an answer, at least for Ubuntu 14.04

as for how to get the keyboard to light up before the login screen:

edit :

/usr/share/lightdm/lightdm.conf.d/50-unity-greeter.conf

sudo gedit /usr/share/lightdm/lightdm.conf.d/50-unity-greeter.conf

add the line:

greeter-setup-script= xset led 3 
1
  • Is there a way to set the brightness level of the keyboard? As opposed to simply turning it on at the lowest setting? – Andor Kiss Apr 30 '19 at 18:52
3

Just try to type in terminal : Turn on :

xset led 3 

Turn off :

xset -led 3

it works for Cool Master Keyboard

2

Found the answer after a long night up with lots of half baked solutions.

# backup your symbols file
sudo cp /usr/share/X11/xkb/symbols/us{,.distribution} 

Add the following line in the xkb_symbols "basic" { section. do not worry if that second line is not there, it is only there for some languages and was not there for us on my system.

...
    modifier_map Mod3   { Scroll_Lock }; <==<< Add this line

    include "level3(ralt_switch)" <==<< before this line
};

You may have to do the same in your other layouts if you switch between languages

Also, there is a cache where xkb layouts live. You should clear it before restarting your X server to check the new keyboard symbol file(s).

sudo rm -f /var/lib/xkb/*
2

For my Mi laptop keyboard, above solutions did not work.

I just had to use that F10 key with the appropriate symbol.

The symbol looks like a bold "dash", with little thin dashes going in every direction and representing light.

1

For a long time, I did this with

xmodmap -e 'add mod3 = Scroll_Lock'

This caused a problem when I started using i3wm. When the backlight was on, the metakey was non-functional. I could turn it on and off with scroll lock and use meta when it was off, but i3 needs that too much and it is too hard to see my keyboard without the light, so this was not an ideal way to do it. The above solution, xset led on is a much better solution. By leaving the keymap alone, I can use meta anytime I need it and always see the keyboard.

1

I just bought an EagleTec mechanical keyboard with blue backlight, and like J. Chomel, found that I just needed to use a key combination to turn the backlight on or off, enable/disable "breathing" mode, or adjust the brightness. In my case, I'm using it on LinuxMint 17, but it should work on other distributions also.

Here are the backlight functions that the keyboard supports:

"FN" + "SCRLK" = Backlight On/Off "FN" + "HOME" = "Breathing" On/Off "FN" + "-" = Lower Brightness "FN" + "=" = Increase Brightness

The keyboard also supports other functions not related to the backlight, although I haven't tried most of them, as I have yet to determine what most of the functions are.

The ones that I do know to work are:

"FN" + "F2" = Lower Volume "FN" + "F3" = Increase Volume "FN" + "F9" = Open Email Application (Thunderbird, in my case)

1

On my Thinkpad T470S with Ubuntu 20.04 -- Keyboard back-light is enabled out of the box. Pressing [Fn-Space] will toggle between keyboard back-light settings on this laptop. Maybe the manual for your keyboard will provide insight into the key combination that might work for its back-light?

1
  • echo 0 | sudo tee /sys/devices/platform/thinkpad_acpi/leds/tpacpi::kbd_backlight/brightness echo 3 | sudo tee /sys/devices/platform/thinkpad_acpi/leds/tpacpi::kbd_backlight/brightness This is the way I switch it on/off askubuntu.com/questions/644410/… – xerostomus Mar 14 at 12:47
0

If your using an Hp Omen if you press Fn and the lighting key you can toggle keyboard backlight on and off using ubuntu studio

0

For the people with LK Gaming keyboards, use fn+F12.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.