I was able to install Ubuntu 12.04 using the alternative version of the image, (64 bit) but when I start the system it tells me the GPU locked up, and instead presents a text only screen.

I understand that this site is not for bug reports, but at the same time, I know that there are some versions of the installer than have to be compatible with my graphics card (Nvidia GTS 360M).

I assumed that the mere fact that the alternative installer ran was an indication that I could get some sort of graphical interface running after the install.

Is there some way of getting some type of graphical interface running on my machine? Even better would be is there a way to get the rest of the system running as normal (i.e. GPU up and running)?

If an internet connection is required to download driver support or something similar, directions for how to configure a wireless connection with WPA2-Personal protection from the text-only interface (bash).

Any help would be appreciated.

Note: I was able to find this which tells me that the card is supported.

Note 2: In the install software stage of the install, I was unable to install anything (no internet connection)

Update: The exact error message is [8.591394] [drm] 0000:01:00.0: GPU Lockup - switching to software fbcon

Update 2: If I try to install with the regular version of Ubuntu, the screen goes staticy. This also happens if I install with Wubi (distasteful I know) and then try to use Ubuntu.

Update 3: I've tried xforcevesa, nomodeset and xforcevesa nomodeset as my wubi boot options.

Update 4: Thanks to jokerdino, I can now connect to the internet, so internet tools would now be a possibility.


Install the Nvidia proprietary driver. In a console do:

sudo jockey-text -e xorg:nvidia_current

Then reboot.

  • It did installed, but unless there are other commands that needed to be run, it did not work. – soandos May 29 '12 at 3:31
  • 1
    I spoke too soon. It does work, but requires two reboots to make it work. After the first reboot, it has be be activated (perhaps it was not required to reboot before that?) – soandos May 29 '12 at 3:38
  • Weird. Perhaps that is an oddity of the command line client. When you use the graphical installer, you only need to reboot once. – Alistair Buxton May 30 '12 at 11:26

You may try using the nouveau driver, using sudo apt-get remove nvidia-current, followed by sudo apt-get install nouveau If you are currently using nouveau, remove it by running sudo apt-get remove nouveau, and install nvidia-common, assuming you have a running system installed and at least able to connect to the internet and get a wrking command-line. Once you remove and install the new driver, be sure to reboot.

  • Wouldn't update 3 take care of this? – soandos May 25 '12 at 21:55
  • @soandos I don't have an Nvidia GTS 360M to test it, but I am not seeing problems with an Nvidia GTX 590(except for no SLI). Have you tried the nouveau driver? – nanofarad May 26 '12 at 16:36
  • 1
    nouveau is what you get by default. Also, "GPU lockup" is a message printed by nouveau when it breaks. – Alistair Buxton May 28 '12 at 20:07
  • @Alistair My bad, sorry. – nanofarad May 28 '12 at 21:10

Try rolling your nvidia driver back to 295.40, this just fixed a few issues like this with my 12.04 x64.

  • Do you mean in windows? – soandos May 25 '12 at 0:04
  • In ubuntu you can set your driver. – dibs May 25 '12 at 2:12
  • 1
    How can I do that? Keep in mind command line only. – soandos May 25 '12 at 2:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.