0

I ran some code with little too many threads and my computer crashed. When I rebooted, I got the "Please select boot device" menu. I tried switching different booting options but nothing worked. I am now booted from USB. The disks application claims my disks are fine. I have some important work files I want to recover. How can I fix the boot thing since the disks are "fine" and how can I recover my files?

Image from Disks application here

After some sniffing around I found my work files. The issue now is how to fix this.

I ran this answer. It ran successfully but nothing changed

Results from gparted :

ubuntu@ubuntu:~$ gparted
Unit boot.mount does not exist, proceeding anyway.
GParted 1.0.0
configuration --enable-libparted-dmraid --enable-online-resize
libparted 3.3
1
  • 1
    Personally, I don't understand your question or your answer. It's not clear from your description what you did that caused the problem, and your answer doesn't provide any details/instructions that someone could actually follow if they did need to fix that problem. It's always better to provide exact instructions instead of narrative descriptions that are ambiguous.
    – Nmath
    Jan 14 at 18:52
0

I fixed it. It seems likes after the crash the boot option for my SSD was void. I reset it to Ubuntu and it works now. I guess 100 threads were too many.

4
  • Maybe you should mark your own answer as the accepted answer ?
    – Luuk
    Jan 14 at 18:34
  • @Luuk you have to wait two days before SE will allow you to mark your own answer as accepted.
    – Nmath
    Jan 14 at 18:37
  • Welcome to AskUbuntu! Since you answered your own question, you can mark it with a green tick as accepted.
    – dlin
    Jan 14 at 18:37
  • @Nmath, absolutely, I did not comment that it should be accepted now or even today.
    – dlin
    Jan 14 at 18:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.