I know this subject has been discussed many times. I have applied almost every fix that I can find on the internet, but every time my Ubuntu18.04 systems starts I get a Software Updater popup.

I have an Ubuntu 18.04 PC running a single 'Kiosk' application with a touch screen. I'm also using Overlayroot to create a Read Only operating system. This system does not need updates - ever.

in the GUI Software & Updates utility I have set 'check for updates' to Never. I have turned off all Update Notifications, I have even now uninstalled Unattended Updates. But every time my PC starts about 1 minute later the Software Updater pops up with 'Updated software is available for this computer'.

I assume that somehow when I was building the system, and had it in Read/Write mode, a potential update, found itself onto the hard drive and now sits there notifying me of its existence every time I boot the system in Read only mode - that is to say that the notification is permanently stored in the Read Only drive. It even pops up when there is no network connection. However, I put the system back into Read Write mode and cancelled the notification, but still it persists.

Where is this notification coming from? Is there some file I need to delete?

  • How behind on system maintenance are you? What is the output of sudo apt update?
    – Nmath
    Jan 12, 2022 at 8:30
  • Update notifier should not appear if the logged in user does not have sudo permissions. So the solution may be to have your kios system boot to a user not belonging to sudo group.
    – vanadium
    Jan 12, 2022 at 8:54
  • The system was built from scratch about 4 weeks ago. I did a full update / upgrade then and basically don't want / need anymore.
    – Mike Young
    Jan 12, 2022 at 9:18

1 Answer 1


I see two options:

  1. Confirm (and perhaps set) the notifier to not show notifications

    • Check to see if notifications are set to appear via the Terminal:

      gsettings get com.ubuntu.update-notifier no-show-notifications

      If the value returned is false, then ...

    • Set no-show-notifications to true:

      gsettings set com.ubuntu.update-notifier no-show-notifications true
  2. Uninstall the notifier

    sudo apt remove update-notifier

In the event the kiosk is scheduled for manual maintenance, you can still update/upgrade the system via the Terminal with the standard apt commands 👍🏻

  • Hi matigo Thanks for the suggestions. I ran the sudo apt remove update-notifier and so far - about 48 hrs so good. No sign of the popup.
    – Mike Young
    Jan 14, 2022 at 8:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.