0

This has started to happen after I encrypted my home folder (this was done after the installation, not as a part of it)... This was in 11.10.

I have since upgraded to 12.04 and after first reboot everything worked well. However since reboot after this, the messages started to pop up again before the actual KDM login prompt.

I am using Kubuntu 12.04 and I have tried different things such as permissions 777 for /tmp, removing everythign from /tmp or even deleeting ~/.kde or ~/.Xauthority etc.

Any ideas?

2

I had the same issue and found that my /home/USER/.kde folder was owned by root, which was causing permissions issues. After fixing the ownership issues with 'chown', things worked as expected.

Do this in terminal:

cd ~/
sudo chown -R <user> .kde
1
  • Good answer, @Dave, this worked for me. I have edited the answer to include the commands.
    – kbuilds
    Apr 11 '14 at 15:00
1

I could login after renaming my ~/.kde folder. Apparently something was corrupted and renaming the folder causes creation of a clean version. You will probably loose settings but at least you can login.

0
0

Logon with gnome, and try create another user, for some reason that I don't know, the config files for kde are invalid.

That worked for me.

1
  • If you don't have GNOME or another non-KDE desktop environment, you can log in non-graphically on a virtual console (Ctrl+Alt+F1) and use adduser to create a new user account. For example, adduser --add_extra_groups USERNAME, then make sure to specify sudo as an additional group when prompted (or admin, if using an Ubuntu release prior to 12.04 LTS). However, I'm not sure if Israel Lins is saying that creating a user outside KDE works in KDE, or just saying to use GNOME instead. Jun 16 '12 at 3:17
0

I found this while searching for this very same problem when a RHEL7 VM that had worked for over a year, suddenly developed this problem. Every reboot and subsequent login as root displayed a small white popup stating: "Call to lnusertemp failed (temp directories full)". Other user accounts could login without a problem. I do not believe the problem is 'ubuntu'-specific based on this research.

With careful experimentation, I found that, for good reason, I'd recently added the following to /root/.bashrc: export TMPDIR=~/tmp

The problem with doing that, was /root/tmp did not exist. Either adding the target directory or commenting that line out immediately solved the problem on subsequent boots. Other testing proved that the same problem could be foisted upon plain user-accounts too.

So, either create the target directory, or don't put that in .bashrc for the applicable user. Good luck!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.