23

I am using LibreOffice 3.5.3.2 (Ubuntu 12.04) and the buttons to switch tabs in Calc are written with small fonts. They're so small I can't even read what is written on them.

I could not find a way to increase font size. Is this problem happenning only with me? Does anyone know a way to increase the font size of sheet names?

2
  • I was using Orta as my system theme... I liked it very much, but it was the cause of sheet titles being in such small fonts. I changed the theme and now things are fine. Unfortunately I wont be able to continue using Orta theme.
    – Rafael
    May 18, 2012 at 0:41
  • Did you try to modify the theme's font size or the LibreOffice UI font size? In both cases you can continue using the Orta theme.
    – tohuwawohu
    May 18, 2012 at 11:48

6 Answers 6

27

I had similar problem with elementary theme. Although the problem was that the scrollbars were too thin. The fix was to modify the scrollbar width in gtkrc file, in my case:

/usr/share/themes/elementary Dark/gtk-2.0/gtkrc

find:

GtkScrollbar            ::slider-width

and set the value to something like 10

5
  • Thanks for this answer. It worked best for me (as opposed to above options which I also tried) because: 1) it allowed me to keep my theme as is 2) and only altered the problem of small sheet names - although of course all my scroll bars got thicker - but that was good for me. My theme was Ambiance so my gtkrc file was in /usr/share/themes/Ambiance/gtk-2.0/. It is also worth noting that I had to find the line with GtkScrollbar - there are a number of lines with slider-width. I am on Ubuntu 12.04.
    – birdsarah
    Jun 19, 2012 at 13:50
  • 1
    This works for me on 14.04 too. Thanks!
    – Ikon
    Aug 25, 2014 at 13:54
  • On 14.04 LTS it was already 13! I doubled the value to 26 and it did the trick. The accepted answer did not work on 14.04 LTS! Backup the file before to change the value so you can restore it if necessary. Jan 13, 2015 at 9:53
  • I am not able to get this to work on 14.04. I changed GtkScrollbar::slider-width to 26, but nothing.
    – HRJ
    Sep 29, 2015 at 6:24
  • Update: changing the slider-width did affect Firefox, but not LibreOffice (on Ubuntu 14.04).
    – HRJ
    Nov 18, 2015 at 13:43
11

Different themes can have different effect on applications. Sometimes this can cause serious problems as shown below. Sheet tabs are hardly readable in first theme but are very clear in second theme.

enter image description here

enter image description here

So changing your system theme can solve this problem.

1
  • 5
    Please note that this problem has been solved in LibreOffice by moving the tabs below the scrollbar, so that themes stop messing with the tabs’ size. The change is available since LibreOffice 4.4.
    – fitojb
    Jan 4, 2015 at 0:28
4

If your preferred theme shows too small fonts in the UI components of LibreOffice, you could just scale the textual UI elements (between 80% and 130%) while keeping the theme. LibreOffice has an option for scaling in Menu Options -> LibreOffice -> View:

View Options

So, you can modify the font size between

80pro (80 percent)

and

130pro (130 percent).

Note: This will affect all textual UI elements, also menu entries and so on - not only the sheet labels.

Another alternative would be to keep the theme but modify the font settings system-wide. Gnome's appearance settings allow for modifying the font even if a certain theme is selected.

More Info:

2
  • Thank you for this answer... it'll be very helpfull when I shift back to Orta theme.
    – Rafael
    May 21, 2012 at 19:57
  • That did not work for me. It looks like the tabs are still very small and the rest becomes huge... not feasible for me. Oct 21, 2014 at 0:32
2

I found this in a file called ~/.themes/Zen-bicolor/gtk-2.0/apps/libreoffice.rc and I copied it to ~/.themes/Zen-bicolor/gtk-2.0/gtk-widgets.rc

            style "large_scrollbar"
            {
            GtkScrollbar::slider-width = 15
            GtkScrollbar::trough-border = 3
            }
            widget_class "*" style "large_scrollbar"

Seems somebody already fixed the problem, just had to move it to a file where it would get picked up. It should affect everything but so far nothing else seems mis-sized and libreoffice is useable again.

0
0

Open any of the Libre Office programs, the go to:

Tools / Options, then select LibreOffice / View, and Change User Interface / Scaling to more than 100%.

This will change the environment proportionally.

0

A quick fix is to click on view, zoom, zoom, change the 100% to 150%.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.