I went to "System Settings", "keyboard", "shortcuts", "custom shortcuts", I added a custom shortcut and called it "task manager" in the "command line:" I typed "gnome-system-monitor", and I gave it the command, "ctrl+alt+del", I apply that and close it. Then I try it and get NOTHING...... why??

  • Does it work in gnome shell but not in unity? Maybe the shortcut is taken by something else... Try in gnome-shell to bind /usr/bin/gnome-system-monitor to some non-obvious shortcuts ! – jasmines May 17 '12 at 20:17

In fact, you cannot use Ctrl+Alt+Del as your shortcut, because it is taken by a logout message, as I just checked:

logout dialog

In order to enable it, you have to go to the keyboard shortcuts you went before, and disable that shortcut or give it another key binding:

keyboard shortcut

Then, you will be able to add your custom shortcut. In order for this to work for sure, you have to completely disable the other shortcut:

disabling the shortcut

In order to do this, select the shortcut and press the Backspace button.

Now, you have to go to the Custom Shortcuts section and add a new shortcut, containing the following:

new shortcut creation

Name: Whatever relevant

Command: gnome-system-monitor

I did this and it works fine in Ubuntu 12.04!

  • I already disabled the "logout" option because i had to, but it still isn't doing anything when I hit "ctrl+alt+delete" – Jon May 17 '12 at 20:35
  • Please check my edited answer! – hytromo May 17 '12 at 22:23

In the command-line(space for the command) you have to enter


How to find the command-

In linux to find a command to exicute a particular program you have to enter in the terminal the following command-


For e.g for the above example you will get a screen like this when you put

whereis gnome-system-monitor


the 1st line "/usr/bin/programname" is the command you have to put/use/execute.

then add the key-binding(use something else like alt+cltr+menu.the one you used is assigned to something else) and save.It will work. :)

How to add in settings-

Open System Settings > Keyboard >Shortcuts tab > custom shortcuts >"+" button > in the name "System Monitor" or anything you want >in the Command space "/usr/bin/gnome-system-monitor" (all small case) > apply.

key bindimg

then click on the space where "Disabled" is writen and press the kay combination(other than alt+cltr+del.it is assigned to log out) for e.g as seen in picture, i had assigned alt+cltr+menu(the right-click menu button on the right of space bar)

if you still want to assign alt+cltr+del as the key binding,change the one for log out in the "system" option there and then assign it to this.

  • forgive me cause I'm a newbie with Ubuntu, coming from windows recently. I tried entering "/usr/bin/gnome-system-monitor" (without quotes) in the command line and it didn't work, but I'm probably misunderstanding you. – Jon May 17 '12 at 20:33
  • I'll give you a photographic tutorial step by step as another answer wait. :) – Nirmik May 17 '12 at 20:37
  • ok, awesome! i appreciate it! – Jon May 17 '12 at 20:40

In the default configuration of Ubuntu 12.04 (do not know in others) Ctrl+Alt+Del is set to close session shortcut. Make sure you have disable this or changed it to another shortcut.

(Sorry it is in Spanish, its the first line. It is deactivated)

enter image description here

Then you can set your custom shortcut to Ctrl+Alt+Del:

(The last one)

enter image description here

If it does not work, try to restart your session (Not sure if reboot is needed) and check that the values are still the ones you set.

  • I disabled the logout command, and restarted my computer, my new shortcut keys are still there and it still doesn't do anything when I try those keys. – Jon May 17 '12 at 20:37
  • What release are you using? – Ángel Araya May 17 '12 at 20:49
  • it's Ubuntu 12.04, i have gnome advanced settings installed, maybe that has something to do with it?? – Jon May 17 '12 at 21:05
  • Advance settings doesn't have to do anything about it. Try to set a different combination set to the same command to make sure where is the problem. Also re-check the command its exactly 'gnome-system-monitor' – Ángel Araya May 17 '12 at 23:19
  • I think you shouldn't have posted those screen shots. – Ufoguy Dec 9 '13 at 11:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.