I just connected an HP Deskjet 1000 series to a 148b HP notebook. The notebook reads the printer as (HP Deskjet 1000 j110). After the driver installed and the printer made available under "printing" app," a print test.

Right-clicked the printer icon and selected properties. Under the "settings" tab, I selected "print test page". The "printer state" notification box displayed, "processing-sending data to printer. Then it changes to, "idle-sending data to printer". Which at this point nothing happens. I did this multiple times. Also, re-installed the printer driver. Still the same issue.

I tried the same printer on my desktop running ubuntu 12.04 with unity. The printer works fine.

Is there a reason why this would happen?


I just had the same problem, although mine was an HP Deskjet 1300, and was able to solve it after installing the HP CUPS packages found in Synaptic, and the hplip package.

Afterwards I opened "printing", just as you did, but instead of going to properties of the identified printer, I decided to add another one. This time I chose "USB" as the root for the printer, and then, after the system searched for the drivers, I selected the box for "Duplexer Installed".

I changed the name of the printer by adding a letter "a", so I did not get confused in between the printers installed, and it worked just fine.

I am not a pro, I just messed around a bit and I am not sure if the packages I downloaded had anything to do, however, I had not seen the "Duplexer Installed" box before.

Finally, I just removed the previous installed printer.

Good luck!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.