When trying to install WINE (sudo apt-get install wine) I get the following error:

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 wine : Depends: wine1.5 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Google does tell me that apparently this has something to to with ia32-libs, but I cannot find out how to do to fix the dependencies or if I need to (manually?) install something else.

I have added ppa:ubuntu-wine/ppa to my repositories.

sudo apt-get install wine1.5gives me

The following packages have unmet dependencies:
 wine1.5 : Depends: wine1.5-i386 (= 1.5.4-0ubuntu1~ppa1~precise1+pulse17)

sudo apt-get install wine1.5-i386gives me

The following packages have unmet dependencies:
 wine1.5-i386:i386 : Depends: libgphoto2-2:i386 (>= but it is not going to be installed
                     Depends: libgphoto2-port0:i386 (>= but it is not going to be installed
                     Recommends: gettext:i386 but it is not going to be installed
                     Recommends: libsane:i386 but it is not going to be installed

Any help would be appreciated. Thanks.


I had a similar problem with broken dependencies when trying to install wine and acroread, and a complaint when trying to install ia32-libs-multiarch, just after upgrading to 12.04 from 11.04 (passing over 11.10). It seems that some ppa's I had in 11.04 installed newer versions of applications in the system. After upgrading, the remains of these apps seemed to do some mess in the dependencies.

The solution that seems to work (until now), was found on a german ubuntu board (http://forum.ubuntuusers.de, posts from user Lasall):

First a downgrade is required and done with the following: create the 'preferences' file:

sudo vi /etc/apt/preferences

and insert the following lines:

Package: *       
Pin: release a=precise*
Pin-Priority: 2012

enter :wq to write the file. Pin-Priority must be greater than 1000.

Then you may downgrade the offending applications with:

sudo apt-get dist-upgrade

Then you may install packages that complained about dependencies, like sudo apt-get install ia32-libs-multiarch, or sudo apt-get install ia32-libs.

Finally, you should remove the file you just created:

sudo rm /etc/apt/preferences

because else no new updates would be found.

Hope this helps you too!

| improve this answer | |
  • Hah! This fixed a bug I've had with installing Wine in 12.10. Thanks a lot! – carestad Nov 1 '12 at 0:36

This is what worked for me in ubuntu 12.04.2 LTS


gksu gedit /etc/apt/preferences.d/base-files

Paste & Save

Package: *       
Pin: release a=precise*
Pin-Priority: 2012

Downgrade Apps Causing The Error

sudo apt-get dist-upgrade

Now We Can Install Wine

sudo apt-get install wine

Finally, remove the file you created

sudo rm /etc/apt/preferences.d/base-files
| improve this answer | |
  • This is a duplicate of JFB's answer. If it is different, please show us how it differs. – jpaugh Jun 15 '16 at 0:27

Try installing Wine by using the Ubuntu Software Center to see if the problem is solved.

You can find some useful help resources for Wine at www.winehq.org/help/, and you can learn more about alternatives to Wine at winehq.org

| improve this answer | |
  • That does not work, either. It gives about the same error message. – Jan May 18 '12 at 6:08

What worked for me in 13.04 64 bit is following David Leo's answer with a small modification to base-files:

Package: *
Pin: release a=raring* Pin-Priority: 2012

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.