0

I have a problem when some shell command is trying to launch my browser. Example below with browse command, but same with jupyter notebook. It looks like the target is opened in VSCode instead.

I'm running Ubuntu 20.04, with zsh, in a pyenv virtual environment.

Thanks!

~ browse askubuntu.com
    command= "code" args= ("code", "http://askubuntu.com")                                                                                                                                
~ Copying QUrl("http://askubuntu.com/")  to QUrl("file:///home/username/.cache/kioexec/krun/8292_0/unnamed")
    Telling kioexecd to watch path "/home/username/.cache/kioexec/krun/8292_0/unnamed" dest "http://askubuntu.com/"
    All files downloaded, will call slotRunApp shortly
    EXEC "/snap/bin/code /home/username/.cache/kioexec/krun/8292_0/unnamed"
    EXEC done

... then VSCode opens the target as a html file.

  • EDIT: Same error when I run xdg-open 'http://askubuntu.com'

  • EDIT: xdg-settings get default-web-browser yields code-2.desktop

  • EDIT: if I do xdg-settings set default-web-browser firefox.desktop, no error raised but it doesn't actually change the value (stays as code-2.desktop)

  • EDIT: $BROWSER askubuntu.com works perfectly fine

  • SOLVED: Thanks to @Koen I went to System settings/Applications/Default Applications (I'm on KDE) --> Web Browser --> Open http and https URLs "in the following application: Firefox" instead of "in an application based on the contents of the URL"

2
  • I meant Ubuntu 20.04.3 LTS
    – edmz
    Dec 30, 2021 at 12:40
  • do a "echo ?" after setting the default web browser - correct value is probably firefox_firefox.desktop
    – Koen
    Jan 1 at 17:26

2 Answers 2

1

You forgot the http:// which defines that what you are browsing is a website instead of a file. when you type "browse" alone you get

xdg-open - opens a file or URL in the user's preferred application

Try browse http:/google.com

This should fix the issue.

1
  • Thanks for your answer but it does not fix the issue. The issue is really that it does not launch my browser. Same when I use jupyter. It opens VSCode instead
    – edmz
    Jan 1 at 16:14
0

xdg-settings fails silently - an echo $? can show you that return code is not 0 when it failed

return codes:

1 Error in command line syntax.
2 One of the files passed on the command line did not exist.
3 A required tool could not be found.
4 The action failed.

browse is a link to xdg-open - so you need to supply an url to open the default browser

the default browser can also be set via gui tools

  • gnome: gnome-control-center - default applications - web
  • KDE: System settings/Applications/Default Applications --> Web Browser --> Open http and https URLs "in the following application: Firefox"
8
  • Thank you, but echo $? yields code 4 when I try setting with firefox_firefox.desktop as well
    – edmz
    Jan 1 at 17:41
  • in my system the desktop files are stored here : /var/lib/snapd/desktop/applications/ - check if you have a desktop file there for firefox
    – Koen
    Jan 1 at 17:44
  • otherwise start gnome-control-center and select the default browser via "default applications" menu
    – Koen
    Jan 1 at 17:53
  • It's /usr/share/applications/firefox.desktop ...while the one actually called is ~/.local/share/applications/code-2.desktop
    – edmz
    Jan 1 at 17:55
  • Great! It works: I went to System settings/Applications/Default Applications (I'm on KDE) --> Web Browser --> Open http and https URLs "in the following application: Firefox" instead of "in an application based on the contents of the URL"
    – edmz
    Jan 1 at 18:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.