0

I'm trying to install the package 'xiphos' on a fresh install of Xubuntu 21.10, but it doesn't appear in the Software Center, and 'apt-search' is unable to locate it. The 'Ubuntu -- Package Search' page shows it as being part of the 'Universe' repository, and I have made sure Universe is enabled and updated, but still nothing.

I notice, however, that the Package Search page adds the tag 'impish (21.10)(gnome)' to the the listing. Does this mean that I need to have the full Gnome desktop installed before apt will let me install Xiphos? If not, how do I get apt (or the Software Center) to let me install it?

(Also: Xiphos isn't available as a snap, and I tried adding a ppa for Xiphos as per this answer, but this information appears to be outdated, since it returns an error: "The user named '~unit193' has no PPA named 'ubuntu/crosswire'")

Edit: I deleted the 'sources.list' file, and renamed 'sources.list.save' as 'sources.list', then updated, but still getting the same error message: "Unable to locate the package xiphos". I also tried searching for xiphos with both uppercase and lowercase capitalization, but still getting the same error message.

Edit 2: The output of the command grep -r ^deb /etc/apt --include=*.list is (note that StackExchange won't allow me to post more than 8 links, so where you see 'ttp://' below, I have removed the letter 'h' to make it inactive):

/etc/apt/sources.list:deb http://archive.ubuntu.com/ubuntu focal main restricted universe
/etc/apt/sources.list:deb http://archive.ubuntu.com/ubuntu focal-updates main restricted universe
/etc/apt/sources.list:deb http://archive.ubuntu.com/ubuntu focal multiverse
/etc/apt/sources.list:deb http://archive.ubuntu.com/ubuntu focal-updates multiverse
/etc/apt/sources.list:deb http://archive.ubuntu.com/ubuntu focal-backports main restricted multiverse universe
/etc/apt/sources.list:deb http://archive.ubuntu.com/ubuntu focal-security main restricted universe
/etc/apt/sources.list:deb http://archive.ubuntu.com/ubuntu focal-security multiverse

Also, the output of sudo apt-get update is:

Hit:1 http://archive.ubuntu.com/ubuntu focal InRelease
Hit:2 http://archive.ubuntu.com/ubuntu focal-updates InRelease
Hit:3 http://archive.ubuntu.com/ubuntu focal-backports InRelease
Hit:4 http://archive.ubuntu.com/ubuntu focal-security InRelease
Reading package lists...

Edit 3: karel, I tried your suggestion with 'wget', and this is the output:

The following packages have unmet dependencies: xiphos : Depends: xiphos-data (= 4.2.1+dfsg1-5) but it is not installable
      Depends: libgdk-pixbuf-2.0-0 (>= 2.22.0) but it is not installable
      Depends: libicu67 (>= 67.1-1~) but it is not installable
      Depends: libsword1.9.0 (>= 1.9.0+dfsg) but it is not installable

I'm planning to work on getting those dependencies soon, but they don't seem to be available with 'apt'.

Edit 4: So I wasn't able to find any of those dependencies, either with 'apt' or 'wget'. Karel & NOrbert I appreciate your time. I've decided to just install a different program, called 'BibleTime'. It's not what I wanted, but at least it installed without hassle. And if even that doesn't work well, then maybe I'll install WINE and eSword instead.

8
  • Please run sudo apt update and add output of apt-cache policy xiphos to the question.
    – N0rbert
    Dec 24, 2021 at 13:15
  • The result was "N: Unable to locate package Xiphos" Dec 25, 2021 at 2:14
  • 1
    Does this answer your question? How do I restore the default repositories?
    – N0rbert
    Dec 25, 2021 at 7:05
  • I deleted the 'sources.list' file, and renamed 'sources.list.save' as 'sources.list', then updated, but still getting the same error message: "Unable to locate the package xiphos" Dec 25, 2021 at 9:59
  • Can't reproduce on fresh VM. Please show all yours source.list - execute grep -r ^deb /etc/apt/ --include=*.list and add the output to the question. Also please run sudo apt-get update and share its output.
    – N0rbert
    Dec 25, 2021 at 12:11

2 Answers 2

2

The Xiphos package is not available in the Ubuntu Repositories for Focal due to 'bad timing' for a fix for an issue in Debian which addresses a build-dependency problem.

Its removal reason initially was:

Debian: #889019, scheduled for removal in Debian, b-d on removed gnome-doc-utils

This means that it was scheduled for removal in Debian, and the build-dependencies on the removed gnome-doc-utils package means that the package could not be built.

However, in June of 2020, gnome-doc-utils was removed from Debian and the build dependency removed from the packages needed to build the xiphos package, and as such the block on xiphos was no longer a concern. As such, Focal is the only supported Ubuntu release that does not ship Xiphos, as that change to remove the blocking package happened after Ubuntu release. And since this is a Universe package, nobody went back to see if it should be synced or added after the fact to -updates, however that is usually rarely done.

One can always backport Xiphos in a PPA for Focal, however it doesn't look like that's being done at this point, and PPAs are not necessarily 'trustworthy' unless you trust the person who maintains that PPA.

1
1

Just use this PPA for Focal. As mentioned in the other answer, Xiphos can be installed from it's official repositories.

sudo add-apt-repository ppa:pkgcrosswire/ppa
sudo apt update
sudo apt install xiphos
0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.