11

After installing 12.04 Precise on my PC, I have encountered some problems with audio output which did no occur when using Lucid.

The sound is choppy and distorted in the lower tones. As I have no experience in setting/testing and doing anything with Audio Devices, I need help even to diagnose the problem.

Update

$ sudo lshw -c multimedia

  *-multimedia  

       description: Audio device
       product: Radeon X1200 Series Audio Controller
       vendor: Hynix Semiconductor (Hyundai Electronics)
       physical id: 5.2
       bus info: pci@0000:01:05.2
       version: 00
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi bus_master cap_list
       configuration: driver=snd_hda_intel latency=32
       resources: irq:19 memory:fdafc000-fdafffff
  *-multimedia
       description: Audio device
       product: SBx00 Azalia (Intel HDA)
       vendor: Hynix Semiconductor (Hyundai Electronics)
       physical id: 14.2
       bus info: pci@0000:00:14.2
       version: 00
       width: 64 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list
       configuration: driver=snd_hda_intel latency=32
       resources: irq:16 memory:fe024000-fe027fff

Update 2

It has something to do with the volume. If the audio is quiet it is not choppy, if the sound is loud then it begins to be choppy.

  • Sorry, what do you mean by "low range"? Doesn't the choppiness and distortion affect all audio? – ish May 17 '12 at 8:21
  • The sound is choppy in general, and distorted for low range tones only. For me it seems like some buffering problem, or something similar. – Misery May 17 '12 at 8:23
  • 1
    Please update question with pastebin of sudo lshw -c multimedia. – ish May 17 '12 at 8:29
  • 1
    I have this same problem... bassy sounds cause chopping/stuttering of playback in videos/audio. turning the volume down low reduces the choppiness. I can't listen to mp3 or watch vlc without sound freaking out. (snd_hda_intel driver for 6/C200 series Intel) – beanaroo May 18 '12 at 10:05
10

Misery, I seem to have found a solution on my system using the same driver (different audio device though)

  1. Open Terminal: gksudo gedit /etc/modprobe.d/alsa-base.conf
  2. Add the following line:

    options snd-hda-intel model=generic
    
  3. Restart System

My audio seems to be working fine now. Full volume, flash content, videos, audio files. Let us know if it helps.


Credit goes to Adityeah

| improve this answer | |
  • it did the thing :] – Misery May 21 '12 at 7:07
  • This has not helped me get sound working correctly in Steam. (For future Googlers) – earthmeLon Nov 15 '13 at 18:32
  • @earthmeLon This solution is for a problem that is system-wide. Not limited to one application. Sorry. – beanaroo Nov 17 '13 at 8:43
  • hey this did not worked for me ? i have intel i5 2nd generation Dell with IDT speakers – Edward Torvalds Nov 15 '14 at 13:28
  • I'll have to test this. – Elder Geek Jan 20 '18 at 22:01
5

A possible solution is disabling "auto-mute" in alsamixer. It is used when the "switch-to-headphone-and-back-again" bug occurs (in high volumes mainly).

First, open your terminal, or press:

CTRL + ALT + T

Then, type and hit "enter":

$ alsamixer

This screen will show up:

Alsa mixer screen in terminal

Use the right arrow until you select "Auto-Mute"

Next, press the down arrow to set it do "Disable" (see the text above it).

Finally, press Esc to apply and exit

That's it.

| improve this answer | |
2

Install alsa-tools:

sudo apt install alsa-tools

Create and save a script in /usr/local/bin:

sudo vi /usr/local/bin/sound_fix.sh

Inside the script, write this:

#!/bin/bash
hda-verb /dev/snd/hwC0D0 0x20 SET_COEF_INDEX 0x67
hda-verb /dev/snd/hwC0D0 0x20 SET_PROC_COEF 0x3000

Run the script as root in a terminal to immediately fix the problem.

Give permission to run using:

sudo chmod 700 [path_to_script_folder]/sound_fix.sh

Run the script using:

./[path_to_script_folder]/sound_fix.sh

To run the script on startup, use cron with the @reboot command:

sudo crontab -e

and then add line in crontab:

@reboot [full_path_to_script_folder]/sound_fix.sh

To run script on resume from suspend, copy the script to

/lib/systemd/system-sleep

For more technical details regarding this fix, check this link.

| improve this answer | |
  • perfect answer, working for 18.04 – Genius Jan 23 at 18:32
0

For crackling noise in headphones especially on the left side.. write a bash script with the following lines

hda-verb /dev/snd/hwC0D0 0x20 SET_COEF_INDEX 0x67
hda-verb /dev/snd/hwC0D0 0x20 SET_PROC_COEF 0x3000

Don't forget to execute it as root.

And for systems which don't have hda-verb installed, you can install hda-verb from the respective package managers

Add the script to the startup scripts or there will be a neccesity to run the script everytime system boots up

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.