The LED light that turns on when I press the mute button on or off, respectively, does not turn on in Ubuntu, yet turns on in Xubuntu. If anyone has any knowledge or help please lemme know!

Btw, this is a Lenovo w520 laptop!


The light doesn't turn on, it's strictly a cosmetic effect, but a nice one!

  • 1
    Is this the speaker mute (left side) button, or the mic mute (right side) button? – ish May 17 '12 at 5:32
  • Probably a duplicate of this question and connected to this bug. If it's just about the LED, then I'm afraid there's no easy workaround for now. – htorque May 17 '12 at 7:17
  • @htorque: I'm intimately familiar with the linked question :) , but the mic led should not be working in Xubuntu either as it's a kernel-related issue. – ish May 17 '12 at 7:34
  • Oops, you are right. If it's working in Xubuntu, it's quite unlikely a dupe of above question - I read over that part. Please don't vote to close! – htorque May 17 '12 at 7:44
  • As I said, this is strictly a cosmetic thing and I would just like for it to work but doesn't change the functionality of the laptop. – cbennett May 17 '12 at 22:45

As the OP hasn't logged in for some time, I am not awaiting the results of the output of the commands requested in the comment, but just posting the solution for my HP laptop.

  1. Start alsamixer in the terminal.

  2. Make sure you've selected the internal sound card (not the HDMI or external ones) by pressing F6.

  3. Try to locate a setting for LEDs, presented between the sliders. In my case it lists a Mute-LED Mode. Use the to move to the right in case you have more sliders than fit on the screen.

  4. Move to the "slider" and adjust it using the and keys in order to find a Follow Master option (or alike). Also try to toggle the LED state manually by flipping the setting On/Off.

  5. Now move to the Master slider and press M to mute/unmute. The LED should toggle with it.

  6. Try to use the hotkeys to mute/unmute. The LED should toggle with it again.

enter image description here

  • I have selected my internal sound device with F6 (HDA Intel PCH) but also tried (default). Unfortunately there is no Mute-LED Mode slider in the list of sliders. – bender Jan 26 '13 at 22:56
  • @bender Do you have the same laptop as the OP (cbennett), a Thinkpad W520? – gertvdijk Jan 26 '13 at 22:58
  • I have a Thinkpad T530 and it's me who started the bounty. – bender Jan 26 '13 at 23:02
  • @bender Ah! That's very relevant information that you have a different model. The T530 is a lot newer and proper hardware support might be on the way still. On my newer HP laptop I need a newer kernel too for the LEDs to work properly. – gertvdijk Jan 26 '13 at 23:04
  • My problem is not completely different. For me, the LED worked while I was using the livecd and stopped working after the system was installed. It's more or less the same as for the question's author. – bender Jan 27 '13 at 0:13

I was unaware that this question never got answered, or that it has been so long, and I just recently (about an hour ago) found the culprit and it was rather simple, I had to remove a couple lines from my /etc/default/grub file that redirected what the ACPI did and now this is working great!

I had to change the grub cmdline default from this:

grub_cmdline_linux_default= "quiet splash acpi_backlight=vendor acpi_osi=linux"

to this:


I found that by removing the acpi_osi = linux line allowed the LED to work, and removing acpi_backlight=vendor allowed me to change the laptop brightness using the slider under brightness and lock. The latter was a separate issue that made me figure out the former.

I deeply apologize for the extreme delay in response as for some reason I neglected to get notifications for this question.


The light that you are talking about is part of a control board connected to the motherboard. If the OS provides a driver for you, the driver will not always work the way it was intended. My wireless light flashes between blue and orange when I move my bluetooth mouse. If Xubuntu had a driver that worked better than Ubuntu, I would check their repositories for the driver in question and use it instead. Try using device manager or something similar to assist you in locating the driver in question.

  • Drivers aren't different between Ubuntu and Xubuntu, as they're running the same kernel. Therefore I believe you can disregard that aspect and it has to be found in the software handling the hotkeys or Alsa/Pulseaudio. – gertvdijk Jan 25 '13 at 16:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.