This question might not be directly related to problems in Ubuntu, but I am still posting this here because it is possible that someone might know of a solution.

I am using Ubuntu 12.04 and am using a Belkin N150 wireless router to connect to the Internet. It seems that there is a problem with using Belkin N150 wireless routers. The Internet connection is very flaky, and the connection drops frequently for a few minutes before it is again re-established.

I found the following link that discusses how to solve this problem on other non-Linux platforms.


It would help if anyone can suggest ways to solve this issue on Ubuntu.

  • I cannot answer this question directly, as I have no experience with this particular router; however, the answer in the link provided for windows 7 would basically be the same for ubuntu. The only difference would be using the network manager to setup the nameservers. Under network manager, select edit connections, under the wireless tab select the connection to your router and select edit. Under IPv4 change method to Automatic (DHCP) Addresses Only, then add the addressed listed in editbox for DNS Servers.
    – Chris
    May 17 '12 at 4:53
  • Are connections to other routers more stable? Could the problem be you wireless adapter in your machine?
    – Chris
    May 17 '12 at 4:55

This may not be a solution to the problem but it's a work around if you have an Android phone (depends on the model and carrier restrictions too).

I bought a Belkin N150 Wireless USB Adapter. It worked great for Windows 7 but when I installed Ubuntu although it paired well, I didn't get good signal and would disconnect most of the times. Belkin has driver for Mac And Windows but not for Ubuntu. I needed the Internet badly (my router is in living room and my study room is far from living room and I was lazy to shop for a compatible new wireless adapter).

It struck to me that Android phones have tethering option. I plugged my phone (Google Nexus)(it works with S3 too) to the Ubuntu System and Turned on the USB tethering option and viola I got a great wired signal and was able to browse and download stuff again from Ubuntu m/c.

That solved my problem temporarily (until I find a right driver or new wireless adapter that works for Ubuntu). Forgot to mention that my phone is connected using WI-FI (also works with 3G).


The setting that seems most relevant is the following: Visit your router settings. Change the channel id and wireless mode. Try using channels 9 or 11. My wireless mode was initially 802.11b&802.11g&802.11n. Changing to just 802.11g seems to help, although my card supports 'n'.


Option 1: First open a web browser and in the address Bar type This will open your router settings. From there click "dns" and change your dns to and you secondary to Which are Google's public dns servers. Now remember you will need to do this to each computer that is having issues.

Option 2: From the router setup page Click on Channel & SSID. From there try changing channels (you may be receiving interference from a different router in your neighborhood). Should that not work try changing wireless mode to 802.11 G only. Again remember that you will need to do this again on each computer with the issue.

Don't forget as well to reboot the router from the router settings page labeled "Restart Router".


what you need to do is to go to belkin website and chat with the web support and they solve your problem in 5 minutes. No much Technical knowledge is needed. OR you can follow the below steps too to get started in 2 minutes. I have done the same with me I am Ubuntu User

Please locate the reset hole on the router. The button will be on the back or side of the router. Use a paperclip (or something similar) to press and hold in the reset button for 10 to 20 seconds and then release it.

Note: The router light will begin to blink. When the router light becomes solid again, the reset is complete.

Connect your modem to the WAN port (Yellow) on your router. Connect the computer to one of the four LAN ports on the router. Open a web browser [Mozilla firefox] and type in the address bar and press Enter on your keyboard. Click on Login in the upper right-hand corner of the page. The router does not ship with an administrator password, so just click on Submit. On left panel, click on Connection Type under Internet WAN and it will prompt for the Router password. By default, there is no password set, so leave it blank and click on the Submit button. Select the Connection Type as PPPoE and then click on Next. Enter the Username and Password provided by ISP, then click on Apply Changes.

  • Check the Internet Status on top right of Belkin Router Setup Page, it should say Connected.

If not, unplug the power cable of Router and Modem; leave it OFF for 30 Seconds. Connect the Power cable to Modem first and then the router.

Then please try accessing Internet wired and wirelessly through the Belkin router. Also check the light status on the router, it should be solid blue now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.