This question already has an answer here:

In Ubuntu 12.04 64Bit, the keyboard shortcut to switch applications (Alt+Tab)is not working

I have done a Full Update/Upgrade.
Keyboard Layout: US
Format: US
Input Source: US
GUI: Gnome Classic

Does any know how to fix this?

marked as duplicate by Eric Carvalho, rɑːdʒɑ, aquaherd, Thomas Ward, Mitch May 11 '13 at 17:59

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.


Workaround until the bug is addressed:

  1. Install & run ccsm:

    sudo apt-get install compizconfig-settings-manager && ccsm

  2. Enable 'Application Switcher' under 'Window Management'

This worked for me

(note that I'm using Linux Mint 13 Maya + 'Gnome Classic' session)


Launch the "keyboard" app from the Dash, and go to the "Shortcuts" tab. See if your shortcut is well configured.

It is located under the "Navigation" category and named as "Switch applications".

  • 1
    Thanks for answering, I already did, and assign Alt + TAB, among other combinations and does not work, works seamlessly in 10.04. – LinuxUser May 16 '12 at 21:03
  • Are you using Unity 2D? I'm using Unity 2D with an Nvidia card that can't run 3D, and I've lost several times shortcut combinations (ALT-TAB among them) after gconfd process hangs, eats up all CPU and I had to manually kill it. Reassign them worked for me. Can you try with a fresh new user? – Awi Jun 10 '12 at 5:50

Download and run CCSM. After opening it, go to Ubuntu Unity Plugin > Switcher (top tab) > Key to start the switcher

Erase/edit whatever keys it says there (change it to anything else). Then click on the right button to Reset it to Tab.

If that doesn't work, you definitely have a system bug, or a faulty keyboard.

Not the answer you're looking for? Browse other questions tagged or ask your own question.