I'm not a big fan of Eclipse but sometimes I use it to deploy apps on Google app-engine. So today morning I woke and was all set to deploy my new python app on Google's app engine and that's when noticed the below quoted error.

An error has occurred. See the log file /home/rupali/.eclipse/org.eclipse.platform_3.7.0_155965261/configuration/1336830746877.log.

I tried running a few commands suggested by forums but they returned with an error.

 sudo update-alternatives --config java

There is only one alternative in link group java: /usr/lib/jvm/java-6-openjdk-amd64/jre/bin/java Nothing to configure.

Help me please !

2 Answers 2


I too had the same problem, it seemed like an older version of java was copied into the home directory under .swt. By Creating a symbolic link to /usr/lib/jni/libswt I was able to solve my issue.

Run the beow command in the terminal to fix it.

ln -s /usr/lib/jni/libswt-* ~/.swt/lib/linux/x86_64/

enter image description here


Or, if ~/.swt/lib/linux/x86_64/ doesn't exist (using 32-bit) this worked for me:

ln -s /usr/lib/jni/libswt-* ~/.swt/lib/linux/x86/

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .