5

Tried to install steam-installer with Ubuntu Software, got this very helpful error:

enter image description here

Then I tried the command line:

$ sudo apt install steam-installer

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 steam-installer : Depends: steam (= 1:1.0.0.61-2ubuntu3)
E: Unable to correct problems, you have held broken packages.

So steam-installer depends on steam, which cannot be resolved! What? Is the Ubuntu Steam package just broken?

Update:

$ sudo apt update
Hit:1 http://mx.archive.ubuntu.com/ubuntu focal InRelease                                                           
Hit:2 http://mx.archive.ubuntu.com/ubuntu focal-updates InRelease                                                   
Hit:3 http://security.ubuntu.com/ubuntu focal-security InRelease
Hit:4 http://mx.archive.ubuntu.com/ubuntu focal-backports InRelease
Reading package lists... Done
Building dependency tree       
Reading state information... Done
6 packages can be upgraded. Run 'apt list --upgradable' to see them.
$ sudo apt upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages will be upgraded:
  libssl1.1 openssl python3-software-properties software-properties-common software-properties-gtk
  ubuntu-advantage-tools
6 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 2 902 kB of archives.
After this operation, 13.3 kB of additional disk space will be used.
Do you want to continue? [Y/n] 
Get:1 http://mx.archive.ubuntu.com/ubuntu focal-updates/main amd64 libssl1.1 amd64 1.1.1f-1ubuntu2.10 [1 322 kB]
Get:2 http://mx.archive.ubuntu.com/ubuntu focal-updates/main amd64 openssl amd64 1.1.1f-1ubuntu2.10 [620 kB]
Get:3 http://mx.archive.ubuntu.com/ubuntu focal-updates/main amd64 ubuntu-advantage-tools amd64 27.4.2~20.04.1 [859 kB]
Get:4 http://mx.archive.ubuntu.com/ubuntu focal-updates/main amd64 software-properties-common all 0.99.9.8 [10.6 kB]
Get:5 http://mx.archive.ubuntu.com/ubuntu focal-updates/main amd64 software-properties-gtk all 0.99.9.8 [66.0 kB]
Get:6 http://mx.archive.ubuntu.com/ubuntu focal-updates/main amd64 python3-software-properties all 0.99.9.8 [24.9 kB]
Fetched 2 902 kB in 4s (661 kB/s)                      
Preconfiguring packages ...
(Reading database ... 418427 files and directories currently installed.)
Preparing to unpack .../0-libssl1.1_1.1.1f-1ubuntu2.10_amd64.deb ...
Unpacking libssl1.1:amd64 (1.1.1f-1ubuntu2.10) over (1.1.1f-1ubuntu2.9) ...
Preparing to unpack .../1-openssl_1.1.1f-1ubuntu2.10_amd64.deb ...
Unpacking openssl (1.1.1f-1ubuntu2.10) over (1.1.1f-1ubuntu2.9) ...
Preparing to unpack .../2-ubuntu-advantage-tools_27.4.2~20.04.1_amd64.deb ...
Unpacking ubuntu-advantage-tools (27.4.2~20.04.1) over (27.4.1~20.04.1) ...
Preparing to unpack .../3-software-properties-common_0.99.9.8_all.deb ...
Unpacking software-properties-common (0.99.9.8) over (0.98.9.5) ...
Preparing to unpack .../4-software-properties-gtk_0.99.9.8_all.deb ...
Unpacking software-properties-gtk (0.99.9.8) over (0.98.9.5) ...
Preparing to unpack .../5-python3-software-properties_0.99.9.8_all.deb ...
Unpacking python3-software-properties (0.99.9.8) over (0.98.9.5) ...
Setting up libssl1.1:amd64 (1.1.1f-1ubuntu2.10) ...
Setting up python3-software-properties (0.99.9.8) ...
Setting up ubuntu-advantage-tools (27.4.2~20.04.1) ...
Setting up openssl (1.1.1f-1ubuntu2.10) ...
Setting up software-properties-common (0.99.9.8) ...
Setting up software-properties-gtk (0.99.9.8) ...
Processing triggers for dbus (1.12.16-2ubuntu2.1) ...
Processing triggers for shared-mime-info (1.15-1) ...
Processing triggers for desktop-file-utils (0.24-1ubuntu3) ...
Processing triggers for mime-support (3.64ubuntu1) ...
Processing triggers for hicolor-icon-theme (0.17-2) ...
Processing triggers for gnome-menus (3.36.0-1ubuntu1) ...
Processing triggers for libglib2.0-0:amd64 (2.64.6-1~ubuntu20.04.4) ...
Processing triggers for libc-bin (2.31-0ubuntu9.3) ...
Processing triggers for man-db (2.9.1-1) ...

Update2:

$ sudo apt install steam
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 steam:i386 : Depends: libgl1-mesa-dri:i386 (>= 17.3) but it is not going to be installed or
                       libtxc-dxtn0:i386 but it is not installable
              Depends: libgl1-mesa-glx:i386 but it is not going to be installed
              Depends: libgpg-error0:i386 (>= 1.10) but it is not going to be installed
              Depends: libudev1:i386 but it is not going to be installed
              Depends: libxcb-dri3-0:i386 (>= 1.11.1) but it is not going to be installed
              Depends: libxinerama1:i386 (>= 2:1.1.1) but it is not going to be installed
              Depends: libc6:i386 (>= 2.15) but it is not going to be installed
              Depends: libstdc++6:i386 (>= 4.8) but it is not going to be installed
              Depends: libx11-6:i386 but it is not going to be installed
              Recommends: libxss1:i386 but it is not going to be installed
              Recommends: mesa-vulkan-drivers:i386 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

sources.list:

#deb cdrom:[Ubuntu 20.04 LTS _Focal Fossa_ - Release amd64 (20200423)]/ focal main restricted

# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.
deb http://mx.archive.ubuntu.com/ubuntu/ focal main restricted
# deb-src http://mx.archive.ubuntu.com/ubuntu/ focal main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://mx.archive.ubuntu.com/ubuntu/ focal-updates main restricted
# deb-src http://mx.archive.ubuntu.com/ubuntu/ focal-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://mx.archive.ubuntu.com/ubuntu/ focal universe
# deb-src http://mx.archive.ubuntu.com/ubuntu/ focal universe
deb http://mx.archive.ubuntu.com/ubuntu/ focal-updates universe
# deb-src http://mx.archive.ubuntu.com/ubuntu/ focal-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu 
## team, and may not be under a free licence. Please satisfy yourself as to 
## your rights to use the software. Also, please note that software in 
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://mx.archive.ubuntu.com/ubuntu/ focal multiverse
# deb-src http://mx.archive.ubuntu.com/ubuntu/ focal multiverse
deb http://mx.archive.ubuntu.com/ubuntu/ focal-updates multiverse
# deb-src http://mx.archive.ubuntu.com/ubuntu/ focal-updates multiverse

## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
deb http://mx.archive.ubuntu.com/ubuntu/ focal-backports main restricted universe multiverse
# deb-src http://mx.archive.ubuntu.com/ubuntu/ focal-backports main restricted universe multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
# deb http://archive.canonical.com/ubuntu focal partner
# deb-src http://archive.canonical.com/ubuntu focal partner

deb http://security.ubuntu.com/ubuntu focal-security main restricted
# deb-src http://security.ubuntu.com/ubuntu focal-security main restricted
deb http://security.ubuntu.com/ubuntu focal-security universe
# deb-src http://security.ubuntu.com/ubuntu focal-security universe
deb http://security.ubuntu.com/ubuntu focal-security multiverse
# deb-src http://security.ubuntu.com/ubuntu focal-security multiverse

# This system was installed using small removable media
# (e.g. netinst, live or single CD). The matching "deb cdrom"
# entries were disabled at the end of the installation process.
# For information about how to configure apt package sources,
# see the sources.list(5) manual.

I think I've never fiddled with that.

19
  • No, it's not broken. It usually installs without issues. Make sure you have a fully update system. Very likely you have other issues that warrant correction before trying to install new software. Dec 7 '21 at 22:23
  • Ubuntu just updated itself today. What other issues might I have? Dec 7 '21 at 22:25
  • 1
    It's not Steam. you have requested an impossible situation normally means that you are not using stock Ubuntu -- you have made changes. Those changes are now preventing Steam from installing. Either revert those changes to return to a stock system, or else edit your question to clear describe those changes so that we can suggest alternatives.
    – user535733
    Dec 7 '21 at 22:27
  • 1
    The steam package is not broken but it looks like your package management system is. Edit your question with the output of sudo apt update and sudo apt upgrade. Please copy/paste the entire output of each into your question.
    – Nmath
    Dec 7 '21 at 22:28
  • In addition to @Nmath's requests, please edit your question and paste in the output of apt policy steam-installer. Also, is there a reason you are not using the official installer from the Steam website steam-latest.deb? Dec 7 '21 at 22:32
4

You are going down a road that will only lead to pain.

Download and install the official package from the Steam website. https://store.steampowered.com/

When you do that, it will install the package steam-launcher and add the ppa steampowered.org

On first run, a bunch of other packages will be installed:

Steam needs to install these additional packages: libc6:amd64 libc6:i386 libegl1:amd64 libegl1:i386 libgbm1:amd64 libgbm1:i386 libgl1-mesa-dri:amd64 libgl1-mesa-dri:i386 libgl1:amd64 libgl1:i386 steam-libs-amd64:amd64 steam-libs-i386:i386 xdg-desktop-portal xdg-desktop-portal-gtk xterm

These packages have a lot of dependencies that also get installed.

Neither steam nor steam-installer gets installed!

Future updates will be handled automatically through the package system.

16
  • 1
    sudo apt install ./steam_latest.deb did succeed. I'll take from that that the Ubuntu Software application is broken. Dec 7 '21 at 23:05
  • 3
    No, Ubuntu Software is not broken and the problem isn't about its focus on snaps. The problem is the store is snap itself therefore, by default, it has access ONLY to the user's space. When you select to open the .deb directly from the browser, as opposed to download it let's say to your "Downloads" folder, the browser downloads it to a temporary folder which is inaccessible to snaps so it errors out. Dec 7 '21 at 23:12
  • 1
    @OrganicMarble You can confirm it in a freshly installed system (VM is fine, obviously). Try to open any .deb directly from the browser and it'll fail. Download it locally and then double-click it and it'll work as it always did. Dec 7 '21 at 23:22
  • 1
    @ChanganAuto: I think the Download Dialog should not offer to open the file with Software Install in the first place, if it's known that that can't work. Dec 7 '21 at 23:28
  • 1
    @OrganicMarble But... but... Think how safer it is now with all this confinement :D Thsi annoyances are small price to pay for such leap forward. That they also use a lot more space not a problem either, even large SSDs are relatively cheap nowadays. Dec 7 '21 at 23:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.