2

I'm here trying to install RStudio IDE on Ubuntu 20.04 LTS, but it asks for some packages needed to be installed. I have downloaded libc6_2.34 from ubuntu packages, this site

https://packages.ubuntu.com/impish/amd64/libc6/download

sudo dpkg -i libc6_2.34-0ubuntu3_amd64.deb

Now I encounter such error

dpkg: regarding libc6_2.34-0ubuntu3_amd64.deb containing libc6:amd64:
 libc6:amd64 breaks locales (<< 2.34)
  locales (version 2.31-0ubuntu9.2) is present and installed.

dpkg: error processing archive libc6_2.34-0ubuntu3_amd64.deb (--install):
 installing libc6:amd64 would break locales, and
 deconfiguration is not permitted (--auto-deconfigure might help)
Errors were encountered while processing:
 libc6_2.34-0ubuntu3_amd64.deb

How do I fix it please HELP!

3
  • Have you tried the --auto-deconfigure flag, as the message suggests?
    – Jos
    Dec 7 '21 at 16:55
  • @Jos good suggestion to get situation even worse. Keep recommending!
    – N0rbert
    Dec 7 '21 at 17:05
  • Just repeating what the message says @N0rbert...
    – Jos
    Dec 7 '21 at 17:41
4

You are trying to kill your system. Do not do it. Libc from 21.10 will not work on 20.04 LTS. They use different API.

Instead use normal deb-package of RStudio which is compatible with both Ubuntu 18.04 LTS and 20.04 LTS.

Open terminal and execute:

sudo apt-get update
cd ~/Downloads
wget -c https://rstudio.org/download/latest/stable/desktop/bionic/rstudio-latest-amd64.deb
sudo apt-get install ./rstudio-latest-amd64.deb
4
  • Thanks for warning me sir, I understand that package for 21.10 will not work on 20.04, but the link you have given "wget -c rstudio.org/download/latest/stable/desktop/bionic/…" still install the version I first used to install rstudio. I have now encountered a new problem, while installing the packages which I shouldn't have I tried to install other packages too now when I try to remove them packages by sudo apt --fix-broken install it warns me to wipe my 391 GB of space which is not even used(I mean I still have 362 GB/500 GB available).
    – sunnyinho
    Dec 8 '21 at 7:10
  • Please add exact error messages with all possible details how did you get there to the original question. If long - use pastebin. Also add the output of grep -r ^deb /etc/apt/ --include=*.list to show us your repositories list.
    – N0rbert
    Dec 8 '21 at 7:31
  • Here on Askubuntu new problem means new question. If above solution solved your issue, you can accept this answer by using grey checkmark at the left of it and then ask new question :)
    – N0rbert
    Dec 8 '21 at 8:24
  • Thank You very much sir for your concern sir but the livepatch setting automatically solved the problem by removing unnecessary packages that I've installed and my adding the right ones.
    – sunnyinho
    Dec 13 '21 at 11:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.