0

My PC has dual boot Ubuntu and Windows 10, installed on separate hard drive.

Some background details: when the PC power on, it goes to the grub menu, and default on Ubuntu. Each time I want to use the Windows, I switch the grub menu (I wrote a bash script, so I usually WOL the PC, SSH in Ubuntu, and run the script and wait for windows start, then I can use windows with Remote desktop)

The problem is WOL only works if I shutdown the PC from Ubuntu. And if I shutdown PC in the Windows, the WOL can never wake up the computer. So each time I finished work with the windows, I restart and let it boot back to the default Ubuntu, then I shutdown the Ubuntu, this way, I can WOL the PC next time.

FYI, The WOL used to work with the Windows before I installed the Ubuntu. The ethernet port is Intel I-219V, on the Windows, I have disabled Hibernate, fast boot, and disabled Ethernet power saving or whatever it called.

Any help on this? What should I look at with the Windows to solve this issue? Or is it supposed to be function like this? Thank you.

3
  • It is a Windows question, here is off-topic. used to work with the Windows before I installed the Ubuntu is probably a perception issue and in any case unrelated to Ubuntu. As a courtesy I suggest disabling Fast Startup in Windows, a must when dual-booting, and probably how it was before some Windows feature update re-enabled it. Dec 3, 2021 at 20:20
  • @ChanganAuto Fast startup/ fastboot, fast shutdown were all disabled. WOL works on the same PC with only Windows installed, before setup dual boot. I posted the same post in Windows comunity, they suggest this is off-topic there, I posted to Superusers community, they suggest this is off-topic as well. I don't know where should I post.
    – Fifi
    Dec 4, 2021 at 19:35
  • No, it's perfectly on-topic at Superuser.com and how could "they" suggest otherwise if you haven't even joined that community / posted any question? Also there's no Windows only stack. The point remains: This has nothing to do with Ubuntu or dual-booting. The situation you described - working before but having to shutdown from Ubuntu in order to work now -, if true, is unrelated. Find out what changed in Windows (feature updates that also tend to re-enable fast startup, by the way, or some other change, or not actually shutting Windows down properly,..) Dec 4, 2021 at 19:43

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.