1

I am attempting to install howdy, and apt yields this result:

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 howdy : Depends: libopencv-dev but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

If I try to install directly libopencv-dev it says the same thigs with other packages.

 libopencv-dev : Depends: libopencv-contrib-dev (= 4.2.0+dfsg-5+20.04.sav2) but it is not going to be installed
                 Depends: libopencv-dnn-dev (= 4.2.0+dfsg-5+20.04.sav2) but it is not going to be installed
                 Depends: libopencv-superres-dev (= 4.2.0+dfsg-5+20.04.sav2) but it is not going to be installed
                 Depends: libopencv4.2-java (= 4.2.0+dfsg-5+20.04.sav2) but it is not going to be installed
                 Depends: libopencv-contrib4.2 (>= 4.2.0+dfsg) but it is not going to be installed

Now I haven't done any work with computer vision before, and I've tried pretty much google offered, among which running the command

sudo apt list --installed | grep opencv

Which told me I had installed the following packages

libopencv-core4.2/focal,now 4.2.0+dfsg-5+20.04.sav2 amd64 [installed,automatic]
libopencv-imgcodecs4.2/focal,now 4.2.0+dfsg-5+20.04.sav2 amd64 [installed,automatic]
libopencv-imgproc4.2/focal,now 4.2.0+dfsg-5+20.04.sav2 amd64 [installed,automatic]
libopencv-videoio4.2/focal,now 4.2.0+dfsg-5+20.04.sav2 amd64 [installed,automatic]

As per the guide I found I removed them, ran autoremove, and then retried with howdy. Same result. How do I solve this? It would be amazing to skip some of the password-typing that linux requires.

Edit: as by request, the result of "apt-cache policy libopencv-dev howdy"

libopencv-dev:
  Installed: (none)
  Candidate: 4.2.0+dfsg-5+20.04.sav2
  Version table:
     4.2.0+dfsg-5+20.04.sav2 500
        500 http://ppa.launchpad.net/savoury1/blender/ubuntu focal/main amd64 Packages
     4.2.0+dfsg-5 500
        500 http://it.archive.ubuntu.com/ubuntu focal/universe amd64 Packages
howdy:
  Installed: (none)
  Candidate: 2.6.1
  Version table:
     2.6.1 500
        500 http://ppa.launchpad.net/boltgolt/howdy/ubuntu focal/main amd64 Packages
        500 http://ppa.launchpad.net/boltgolt/howdy/ubuntu focal/main i386 Packages

The result of apt-cache policy is here

5
  • Please add output of apt-cache policy libopencv-dev howdy to the question by editing it. Do you really need latest OpenCV from PPA?
    – N0rbert
    Dec 1, 2021 at 19:05
  • Added. As far as the version of OpenCV I have no idea which is needed, I thought apt would figure that out (?)
    – JeyNessuno
    Dec 1, 2021 at 19:18
  • Please add output of apt-cache policy to the question (if long - use pastebin).
    – N0rbert
    Dec 2, 2021 at 6:28
  • Here you go @N0rbert
    – JeyNessuno
    Dec 2, 2021 at 10:31
  • Please install Aptitude by sudo apt-get install aptitude and then try to install Howdy using it - by sudo aptitude install howdy. Please share any error output which you get.
    – N0rbert
    Dec 2, 2021 at 10:41

1 Answer 1

1

I would recommend to purge ppa:savoury1/blender PPA by using below commands:

sudo apt-get update
sudo apt-get install ppa-purge
sudo ppa-purge ppa:savoury1/blender

Then you'll be able to install Howdy from its PPA by

sudo apt-get install howdy
3
  • Nope doesn't work... Why did I have to remove blender's PPA? I did install the repo successfully though
    – JeyNessuno
    Dec 1, 2021 at 20:33
  • 1
    Blender's PPA contains conflicting OpenCV libraries.
    – N0rbert
    Dec 1, 2021 at 20:34
  • I guess but it still doesn't work... Running the command again obviously blender is not there anymore, and I definitely cannot remove ubuntu's repo soooo halp
    – JeyNessuno
    Dec 1, 2021 at 22:05

Not the answer you're looking for? Browse other questions tagged or ask your own question.