6

I'm trying to back up my user files from my Android phone (recommended before a possible phone repair) into free space on my Kubuntu 20.04.3 desktop system, but although the notifier tells me when I've connected the phone via USB cable (through a 4-port USB hub that works fine for other things including writing SD cards for my 3D printer, with a cable that the phone accepts for "charging rapidly" though I don't often try to transfer data), any attempt to access files on the phone results in an error message.

I found an answer relevant to older versions of Ubuntu recommending installation of gvfs tools, but comments indicate it's no longer needed since 13.10, as all of those tools are included in newer versions. Presuming it's relevant, I also can't download photos from my phone.

Phone is a first-gen Google Pixel, approaching four years old, and 100% functional aside from greatly reduced battery life, possible accelerometer issues (screen rotation is intermittent), and possible light level sensing issues (screen auto brightness mostly dosen't work, possibly due to a dirty Otter Box).

Do I need to do something special to transfer files (photos, music, downloaded game .apk files) from the phone to the Kubuntu system?

7
  • Many phones are very "picky". Try the original cable or a known good quality cable and, of course, avoid hubs. Dec 1, 2021 at 15:26
  • Watch sudo journalctl --follow as you connect the phone to get more information. Immediately after connecting, ls -lrt /dev will show the device name. Edit your Question to show us.
    – waltinator
    Dec 1, 2021 at 15:46
  • It has been my experience that I have to change a setting on my phone to get my computer to see it as a storage device. On my Android phone it's under Settings > Connected devices > USB preferences > File transfer. Dec 1, 2021 at 20:31
  • @KneadToKnow I don't find anything related to USB Preferences anywhere under Settings. Connected Devices only seems to be about Bluetooth. Phone has Android 10, might be a version difference. 'Doh! Only shows when the cable is connected!
    – Zeiss Ikon
    Dec 1, 2021 at 21:58
  • @ZeissIkon I'm Android 10 also. I find that the USB options only appear when I have a USB cable plugged in, if that helps at all. Dec 1, 2021 at 22:01

1 Answer 1

5

A setting on the phone governs how the computer interacts with it. On my Android 10 phone it's under Settings > Connected devices > USB preferences > File transfer.

Note that to see the USB preferences, it appears that you have to have a USB cable plugged in.

0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .